If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Riffaz 2 months ago.

Assigned support staff: Riffaz.

Author Posts
September 16, 2019 at 2:40 pm #4581619

chromaB

String translation is not working in my website after the last update

September 16, 2019 at 2:55 pm #4581683

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

May I ask what do you mean by 'String translation not working' ?
Do you see any error message when you go to WPML > String Translations? or do you see just a blank page?
Could you please show a screenshot for better understanding?

Regards,
Riffaz.

September 17, 2019 at 9:36 am #4587125

chromaB

The strings are translated, but they are not showing in the frontend.
When i try to resave the strings, suddenly appear "sin traducir"

September 18, 2019 at 7:27 am #4593205

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Your MaxInputVars is 1000.
Could you please increase your MaxInputVars to 10000 and check the issue? hidden link

Also, please make a minor change in the original text of this then translate again.
This should be fixed by then.

Let me know how it goes.

Regards,
Riffaz.

September 18, 2019 at 7:40 am #4593261

chromaB

Than you Rifazz,
I have done this changes and still not working!

September 18, 2019 at 7:50 am #4593365

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Does this happen to all the strings? or only to specific strings?

Regards,

September 18, 2019 at 7:55 am #4593381

chromaB

It doesnt detect new strings and it happens mainly with those.

September 18, 2019 at 7:56 am #4593475

chromaB

But yes, it happens with all strings

September 19, 2019 at 10:13 am #4603511

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please try the following steps after a full site backup and check you are still having the issue.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link at the bottom of page)
3) In Troubleshooting page, please click on the following options of *Clean up* section
- Clear the cache in WPML
- Remove ghost entries
- Fix element_type collation
- Set language information
- Fix post type assignment
4) Please also clear the server-side caches. Maybe a server cache is enabled in the control panel

Let me know how it goes.

Regards,

The topic ‘[Closed] String translation not working after update’ is closed to new replies.