This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 17, 2019 at 3:28 pm #4231769

sebastienR-13

I translated all of my strings in French and Dutch (the two languages used on my website) using the String Translation tab, the Dutch version (default language) is displayed correctly but I have an issue with the French version.
Indeed the only time the translated strings appear in French seems to be on a single post's page / on a page.

Here is the homepage in Dutch and French:
hidden link
hidden link

And here is a post in Dutch and French:
hidden link
hidden link

As you can see, the widget displayed on the left part of the header (next to the logo) isn't translated in French on the homepage but is translated correctly on the post.

I've tried to delete the strings inside the admin, change the language of it (from French to English to French again) but nothing seems to work.

I have no idea why it doesn't work to be honest...

July 17, 2019 at 6:39 pm #4233005

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 18, 2019 at 5:22 pm #4241399

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried to access your website with the provided details but it doesn't seem to be working, I got an invalid password/username message. Can you review it please? A private reply is now enabled for you again, so you ca safely resend these access details. Thank you for your collaboration, have a nice day.

July 19, 2019 at 8:50 am #4245033

sebastienR-13

Hi,

Sorry, indeed the password was wrong and has been updated in my original post.

July 19, 2019 at 5:34 pm #4247705

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

July 30, 2019 at 3:44 pm #4309451

sebastienR-13

Hello Marcos,

Sorry for the delay, I was on holidays.

I just proceeded with the migration but it should take quite a bit more time to complete since we have 80+Go of data on it.

Since I've somewhat hacked my first example (the Latest magazine widget) for it to work in production you should now look inside the footer for the "Onze categories" text.
This text should be "Nos catégories" in French but is only translated on a post or page, even when the posts displayed on the homepage or the archive are in French.

Best regards,
Florian

July 31, 2019 at 12:39 pm #4314411

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Florian,

Thank you for the updates. Please, let me know when you are ready so we can proceed with the needed investigations and the resolution of your issue. Have a nice day.

The topic ‘[Closed] String Translation not working except on post’ is closed to new replies.