This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Noman 3 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
June 20, 2019 at 9:11 am #4057949

gracev

I translated the bottom footer bar text (Contact | Privacy Statement) with the help of 'String translation'. But it doesn't work on the front-end, only the English version is shown.
Link to a page where the issue can be seen: hidden link

Kind regard,
Konrad

June 20, 2019 at 9:28 am #4058099

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Please try to re-save the translation:

1. Go to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

2. Then again go to: String Translation >> Re-add your translated text >> and re-save. Make sure that "Translation is complete" checkbox is selected.

- Please delete all sort of caches on your site / server cache / plugin cache (WP Super Cache) / CDN cache (if any), clear browser cache and then check the page. I would suggest to disable WP Super Cache plugin temporary.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

June 20, 2019 at 10:32 am #4058893

gracev

Hi Noman,

We increased the WP memory limit and disabled/deleted the cache, but that didn't help. Could it be a theme issue (Movedo)?

June 20, 2019 at 11:19 am #4059365

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 23, 2019 at 9:11 am #4072735

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. My off days are Friday and Saturday and now I am available and working on this issue and will update you with findings soon.

Thank you

June 23, 2019 at 11:44 am #4072991

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I can see this issue in your site. To further debug this issue, I need to reproduce this issue in fresh installation. To do that, could you please provide me Movedo theme so that I can debug it further. I have enabled private input box for your next reply.

Thank you

June 24, 2019 at 9:12 am #4075927

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

You can upload it to google drive or dropbox and share the link with us.

Thank you

June 24, 2019 at 10:18 pm #4080017

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for sending the theme. I have tried to reproduce this issue on a fresh WP installation with Movedo theme and WPML, but I am not able to reproduce it. Those strings got translated successfully in my test site. I am going to escalate this issue to our 2nd tier support for further review so they can see why its not working in your site.

Thank you for waiting on this.

June 24, 2019 at 10:36 pm #4080115

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have now escalated this issue to our 2nd tier support for further review. I will update you as soon as I have some news.

Thank you for your cooperation and patience.

June 25, 2019 at 6:26 am #4081543

gracev

Thank you for the help! 2-3 weeks ago we updated to PHP 7.3, I don't know if this could be a issue with the string translation, but I thought it's worth mentioning it.

June 25, 2019 at 8:43 am #4082335

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Okay thanks for letting us know.

July 3, 2019 at 7:02 pm #4138623

gracev

Hi! Sorry for the late reply, but I did the migration. As you can see, the string translation works in the Cloud environment. I guess the issue lies with the hosting provider and there server settings?

July 4, 2019 at 9:42 am #4142045

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

At moment our cloud test server is overloaded so I could not check. But if you have already confirmed its working there. Then it must be server side issue, I suggest to change php version to 7.0 and see if it resolves.

Please take full site backup before. Thanks

July 4, 2019 at 2:32 pm #4144485

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Apart from above solution, also the server may have some dynamic caching system which we cant see but hosting support can cleanup. I have now checked test cloud site and its working fine there like you said above.

Thanks

The topic ‘[Closed] String translation not working (front-end)’ is closed to new replies.