This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Izzi Hassan 2 weeks, 6 days ago.

Assigned support staff: Izzi Hassan.

Author Posts
September 30, 2019 at 4:00 pm

johnK-19

I am trying to: Change "Reservar" in Top Bar in English Version to Book Now with the corresponding link, I have changed in String Translation but not appearing.

The same thing happens on Check Availability below slider although cannot see Original in String Translation

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

September 30, 2019 at 4:40 pm #4666587

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @johnk-19, welcome to the WPML support Forum!

Please try the steps below:
- Make sure you have the Translation Magagement and String Translator extensions active. If not, you can download here: https://wpml.org/account/downloads/
- Go to WPML → Theme and Plugin Localization → Strings in the themes
- Select your theme and click on Scan selected theme for strings
- Go to WPML → String Translation and search for the Strings
- Translate the string, check the Translation is complete field and click on Save.

Ref: https://wpml.org/documentation/getting-started-guide/string-translation/

If you can not find the strings, check it is possible to find it on the Translate texts in admin screen page, like on this link: https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts -Maybe it stores these strings as options.

Please let me know if it worked for you.

All the best,
Diego

September 30, 2019 at 5:28 pm #4666849

johnK-19

I have done all you suggested and I have already translated topbar button in string translation, but it is still not appearing translated in English version hidden link. The Check Availability Button below the slider is translated but I cannot see the URL in String Translation even though I have rescanned the theme and plugin for new strings. Any Ideas? It is only affecting these 2 the rest is translated and working perfectly

October 1, 2019 at 5:24 am #4668779

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi John,

I'll be happy to assist you with this. Could you provide updated login credentials so I can take a quick look?

I went through your debug information and it looks you have already selected the option I would have suggested trying. This seems to be a problem with the way the theme has been coded however, which I'll be able to confirm by taking a look at your WP Admin panel.

October 1, 2019 at 8:53 am
October 1, 2019 at 11:01 am #4671443

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I took a quick look. I'd prefer not to make changes to your website directly, so please follow these steps to translate that button text:

- Go to WPML -> String Translation
- Click on the "Translate texts in admin screens" link at the bottom of the page
- Scroll down and find "+ sohohotel_data" and click on it to expand
- Check the boxes shown in the screenshot below. Your theme provides two options for that button. You should translate both in case you change the button type in the future
- Click the "Apply" button at the bottom of the page
- Go to WPML -> Theme and plugins localization, and check the box for SohoHotel theme as shown in the second screenshot
- Click the "Scan selected themes for strings"
- Go back to WPML -> String Translation, and search for "Reservar" or "top-right-button-text". You should see the two new strings available for translation now

Please let me know if you have further issues with this translation and I'll be happy to assist you further!

October 1, 2019 at 11:33 am #4671647

johnK-19

Many Thanks, it worked perfectly for the top bar button, thank you so much. Can you help me also with the reservation bar below the slider, I have translated everything but cannot see the url in string translation "Booking Page Url". It is using the Soho booking plugin. I have rescanned the plugin but still cannot see it

October 1, 2019 at 12:15 pm #4671939

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Can you clarify which option you're trying to translate? I see that the bar underneath your slider is already translating.

Do you mean about the Booking Page setting in Theme Options?

A screenshot would be useful. For your information, you can view source on the "Admin Texts" screen to see all the options (theme, plugins, WordPress) that are scannable / translatable:
view-source:hidden link

I just searched through this raw dump to find the correct key for the button text:

<input type="checkbox"  name="icl_admin_options[sohohotel_data][top-right-button-text-1]"  value=""  />

This told me that the option "top-right-button-text-1" is in "sohohotel_data".

October 1, 2019 at 12:29 pm #4671985
johnK-19

On this bar, all text is translated, but the URL needs to go to the English version URL. In the back end (see Screenshot) you select the booking page. But what happens when you check room availability in hidden link it goes to the Spanish page rather than the English version. This is the issue I have as I cannot see where to change this

New threads created by Izzi Hassan and linked to this one are listed below:

https://wpml.org/forums/topic/split-cant-select-string-for-tracking-in-string-translation-admin-texts/

October 1, 2019 at 12:36 pm #4672045

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Please follow the same instructions, but check the box shown in the screenshot below:
shb_booking_page.

When you translate this string in the String Translation page, you will need to give the ID of the English page.

October 1, 2019 at 1:01 pm #4672235

johnK-19

I have done what you suggested but still not seeing it appear in the string translation. I am assuming that I search for the Spanish page id, correct?

October 1, 2019 at 1:26 pm #4672413

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I see what the issue is. I'll need to close this ticket out and I've created a new one for that issue.

Keeping each ticket restricted to one issue helps us keep these forums organized and allows other users and supporters find information for related problems easily.

Please mark this ticket as resolved and I'll be happy to continue providing assistance with the second issue on the ticket I just created for you.

October 1, 2019 at 4:19 pm #4673947

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi John,

Just marking this topic resolved. You can find a solution to your next issue here:
https://wpml.org/forums/topic/split-cant-select-string-for-tracking-in-string-translation-admin-texts/

Please let me know when you've had a chance to try it!