This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Bryan 4 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
January 4, 2019 at 5:22 am

Bryan

I am trying to:
I have set up string translation for a plugin (supported)

Link to a page where the issue can be seen:
hidden link

I expected to see:
Japanese after I select a day

Instead, I got:
english all the time - unless I am logged in in which case I get as expected; this is a clean test install of everything with defaults; I have tried various options - like dont load mo files, always load them etc

team booking comes with only english and italian languages files; in this case I am not using them... just to keep it clean.

January 4, 2019 at 6:37 am #3055384

Bryan

I just noticed xserver had a geo block active - I think I turned it off, thanks

January 4, 2019 at 4:47 pm #3057324

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for confirming.
Please close this ticket and open new dedicated ticket if you have an other questions.
We are happy to help.

Regards,

January 5, 2019 at 1:02 am #3058259

Bryan

Sorry this is not resolved - with hindsight I can see how my update could be confusing.

after supplying all the data and login details on the private channel I remembered that xserver.jp block admin login attempts from outside japan. ...and I think I turned that off; its impossible to know without being outside japan.

...none of this affects the problem which feels like either a setting or a bug or an incompatibility with the teambooking plugin. The reason I feel it must be wpml is that String translation works fine when the user is logged in, but not at all from the normal front end(not logged in user)..., regardless of the language they choose on the front end.

the site I sent was created especially to demonstrate the problem - you can make any change you like to it.

thanks

January 6, 2019 at 2:37 pm #3060381

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the delay. I do not work on Friday and Saturday.

This issue usually happens when you use a caching plugin or when your hosting caches the site.
Could you please check this. Remove/clear cache and check if you find any.

Anyhow, I could not check your site because I see this when I try to log in : hidden link

Let me know.

Regards,

January 6, 2019 at 2:48 pm #3060398

Bryan

hi

thanks. I didn't really expect a reply till tomorrow but thanks -- there is no cache turned on as far as I can tell; this site has almost nothing installed.

also I checked the login with the userid and pw supplied and it seems fine ?

if you resend the private form I will reset and try again?

January 6, 2019 at 2:49 pm #3060400

Bryan

sorry I see a typo the userid is

wpml

January 6, 2019 at 6:20 pm #3060627

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

you are welcome.

setting the next reply as private!

January 7, 2019 at 7:01 am
January 7, 2019 at 11:09 am #3062254

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the updated credentials and it works fine now.

Your settings and all translation are fine in your site.
It seems this issue related to your specific site or the plugin.
To make sure please :
1. go to hidden link
2. configure the WPML as you have in your site. At the last steps just click next (site key)
3. install the plugin you are using to create this booking section
4. create a page with calender as you have in your site.
5. reproduce the issue and let me know.
6. also let me know the steps to reproduce issue.

Regards,

January 8, 2019 at 9:48 am #3066046

Bryan

Looks like a bug to me !

I replicated the problem on hidden link

same thing

while logged in I get the single string translation I made - but accessing the same page from another browser (not logged in) I lose the translation as soon as it comes time to use string translation versus - whatever is driving the menu.

The reason I do not think its the plugin - is that it works fine while loggedin but not when logged out !

I added nothing to the site except

japanese language and 2 pages

english
hidden link

japanese same thing
hidden link

try selecting a day

you should see
'Choose a timeslot' in english and タイムリー in japanese ( nonsense translation)

thanks

January 8, 2019 at 9:49 am #3066048

Bryan

oh and of course I added the teambooking plugin and configured it ..

January 9, 2019 at 6:59 am #3069930

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for this!

I've escalated this to 2nd tier.
Please be patient till we get back to you.

Regards,

January 9, 2019 at 7:15 am #3069944

Bryan

Riffaz

thank you - I was just trying to figure how to replicate this on a different plugin - my seem to be lacking the creativity to do it - I have found the teambooking developer is very responsive if we need assistance.

cheers

January 9, 2019 at 10:53 am #3070886

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

That's also a good option.
You can try with them as well and update.
Meanwhile if I get any update from our 2nd tier I will update you as well.

Regards,