Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The widgets translation is not working. Solution: To translate text widgets try the following steps: - Convert the text widgets to Multilingual Widgets - Translate the text in WPML -> String Translation Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-widgets/

This topic contains 12 replies, has 3 voices.

Last updated by dustinN 2 years, 4 months ago.

Assigned support staff: Vincenzo.

Author Posts
June 23, 2017 at 4:31 pm #1304666

dustinN

I am trying to: Use String Translation with widgets, Portfolio entries and my theme's (The7) Benefits. This was all working just fine, but it is not working for any of my translations now.

URL of (my) website where problem appears:
hidden link
hidden link
or /zh-hans/, /zh-hant/, /ko/

I expected to see, but instead, I got:
The English page shows two widgets. 1. "White Knight Pump Accessories" and 2. "® Teflon is a registered trademark of E. I. du Pont de Nemours and Company". These are not being translated.

Also, the Portfolio items and Benefits items are displayed between those two widgets on the English page, but they do not appear on the translated pages.

Steps to duplicate the issue: Take a look at the English homepage and compare it to the translated versions, specifically the Accessories widget and below.

Note: The footer contains widgets, and some of them are being translated correctly but others are not being translated.

June 26, 2017 at 6:15 am #1305261

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for contacting the WPML support. We are happy to help you.

Have you translated these Strings from WPML>>String Translation or WPML>>Translation Editor?

Hope you are following the steps described in this tutorial - https://wpml.org/documentation/plugins-compatibility/visual-composer/

Does it happen after the recent upgrade of a plugin/theme or WordPress? It would be nice if you can provide me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

--
With Regards

Bigul

June 28, 2017 at 3:18 pm #1307693

dustinN

It is String Translation.

I'm not certain when it started. I am using WP version 4.8, and The7 version is v.5.3.0.2.

Here is the paste bin for my WP Debug Log: https://pastebin.com/qkW6FmQM

June 29, 2017 at 7:10 am #1308088

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for the updates. I would like to access admin area of your site for further checking. Please fill the private details fields after a full site backup. Check the following links for more details about private information sharing.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue locally.

--
With Regards

Bigul

July 3, 2017 at 6:32 am #1310281

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the login information, I made a duplicator copy of your site now. Will debug it locally and get back to you as soon as possible. Please wait.

--
With Regards

Bigul

July 3, 2017 at 7:04 am #1310297

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Sorry, one issue. The duplicator package is missing the WordPress, Plugins, and Themes files because of a scanner error. The database file is only included in the package. Please check the attached images for more details.

Therefore please share me your site files as a zip archive. You can share it via dropbox or google drive. If possible please exclude the *wp-content/uploads* folder and media files from the archive.

--
With Regards

Bigul

July 6, 2017 at 6:30 am #1313133

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for the backup file. I will configure and debug it locally. Will get back to you as soon as possible. Please wait.

--
With Regards

Bigul

July 7, 2017 at 10:08 am #1314286

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, my name is Vincenzo.
Since Bigul currently has a few days off, I will replace him here in the forum.
I hope this is OK for you.

Before downloading and testing locally your website, I would like to ask you to do one last test.

Can you please enable the "Translate the theme and plugins using WPML's String Translation and load .mo files as backup" option in WPML -> Theme and plugins localization

Please let me know if this solves the issue or if you need further details.

Thank you

July 7, 2017 at 2:37 pm #1314569

dustinN

Hi Vincenzo. I enabled that option, but it did not solve the issue.

July 7, 2017 at 4:03 pm #1314653

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

if I understand correctly the only remaining issue is the translation of the widgets.

From what I can see most of the widgets are now working.

If some text widget is not translated, can you please try to convert it to a multilingual widget?
Once a text widget is converted to a Multilingual Widget you can translate the text from WPML -> String Translation.

I did it for the Legal Teflon widget and it seems to work correctly.

Please let me know if this solves the issue or if you need further details.

Thank you

July 7, 2017 at 5:14 pm #1314701

dustinN

Converting to Multilingual Widgets solves the issue for Widgets.

However, Portfolio and Benefits items are still not translated. They are not even displaying on the translated pages. I was able to get them to work on the Japanese homepage by editing/saving the page. But, doing that for every page would take weeks.

For examples:
Homepage: hidden link
Working on Ja: hidden link
Not working: hidden link
Not working: hidden link
Not working: hidden link

July 8, 2017 at 9:35 am #1314904

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

glad to hear that the issue with widgets is fixed.

About the issue with Portfolio and Benefits I took a look at the Simplified Chinese translation of the homepage and the issue is caused by the fact that the category chosen is in the original language.
As you already noticed, you need to select the correct category in the "Portfolio Scroller" and in the "Benefits" shortcodes to show the missing items.

You may need to temporarily enable the Manual translation from WPML -> Translation Management -> Multilingual Content Setup -> How to translate posts and pages.
Alternatively, you can manually edit the translations of the pages by using the language switcher on top of the backend when you are on the edit page.

Please let me know if this solves the issue or if you need further details.

Thank you

July 10, 2017 at 4:24 pm #1316012

dustinN

Thanks Vincenzo. I enabled Manual Translation and assigned the Benefits and Portfolio items to categories. That does indeed solve the problem. Thanks for your help.