This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bigul 1 month, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
August 29, 2019 at 1:47 pm

edisonO

I am trying to: Translate a layer slider

Link to a page where the issue can be seen: hidden link

I expected to see: The ability to translate all slides

Instead, I got: Only one slide's main text can be translated

I'm translating a slider using the instructions at https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-using-layerslider-and-wpml/. However, it's only allowing me to change the quotation once, and then is using the same quote on every slide.

August 29, 2019 at 1:59 pm
August 29, 2019 at 7:38 pm #4483241

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I am getting the following error while trying to login to the site. Please check and let me know your feedback.

504 Gateway Time-out

--
Thanks!

Bigul

August 29, 2019 at 8:03 pm #4483467

edisonO

It happens occasionally. It seems to be working now. Thanks!

August 30, 2019 at 9:47 am #4485753

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can log in to the site now. Please check the attached image. Hope you are mentioning this string?

One more doubt. How you are managing slides because the LayerSlider WP>>Sliders menu is not listing the existing slider for me.

--
Thanks!

Bigul

September 3, 2019 at 4:28 pm #4506365

edisonO

It's the "Testimonial Slider" on the lower left of your first image. There's no preview image, so it's hard to see. But yes, that is the string I'm referring to. It won't let me translate the main text on any slide but the first one.

September 4, 2019 at 12:11 pm #4510745

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

4) Then update the slider and check the slider description strings are registered for translation or not

--
Thanks!

Bigul

September 4, 2019 at 4:06 pm #4512743

edisonO

Hi, I followed the steps and it had no effect on the available strings for translation.

September 5, 2019 at 9:04 am #4517335

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Just to make sure, I have a doubt. Have you added the Slide's description text from LayerSlider WP>>Sliders>>Testimonial Slider edit screen?

Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 5, 2019 at 2:14 pm #4520029

edisonO

Yes, that's how the text was added. Please go ahead and do what you need to do in order to fix it.

September 6, 2019 at 8:07 am #4523935

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of the site and debugging the issue now. Will get back to you soon. Please wait.

--
Thanks!

Bigul

September 9, 2019 at 7:59 am #4534223

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, on my local server copy, I am getting the expected result after the following steps.

1) Upgrade to the latest version of Layer Slider
2) Visit WPML>>Support>>Troubleshooting
3) Try *Recreate ST DB cache tables* Action
4) Update the *Testimonial* Slider(just resave)
5) Then visit WPML>>String Translation and search for the strings. Slider description strings are registered under *Deafualt* string domain instead of *LayerSlider*.
6) Translate the strings

I have tried the same steps on your site except the upgrading of Layer Slider. Then translate three Slider Description strings. But only one of them is showing the translation.

So please upgrade Layer Slider after a backup and clear all types of caches. Then check you are getting the translation for the Description strings which are translated.

Please check the attached images for more details.

--
Thanks!

Bigul

The topic ‘[Closed] String Translation On LayerSlider’ is closed to new replies.