This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Unable to register admin texts for string transation

Solution: The client has a max vars issue increasing the PHP max input vars to 5000 resolved the issue for this particular case.

This topic contains 8 replies, has 2 voices.

Last updated by danielK-15 3 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 2, 2019 at 5:08 am #4124039

danielK-15

I use 5 languages and german is my default language... when i use the string translation... most of the strings are found and i can translate them in all languages in the backend... but only in french the translation shows up in the frontend... all other languages the text is still in german (my default)... i tried this with a couple of domains (theme and plugins) ... alyways the same...

July 2, 2019 at 7:37 am #4124715

danielK-15

any news on this issue?

July 2, 2019 at 10:51 am #4125927

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience.

The issue is related to restricted Max input vars, Please increase PHP max input vars to a value of 5000. Your current limit is around 2500.
I am able to resolve the issue in my local environment by increasing the limits as mentioned above.

If you can handle this by yourself and have access to cpanel please refer to the information in the below URL
hidden link

Else you can request your hosting provider to increase the PHP max input vars limit.

I hope this helps you resolve the issue.

Kind regards
Raja

July 2, 2019 at 11:08 am #4126117

danielK-15

hmm i increased it to 5000... same issue... you were able to make the pcfme_billing_settings translatable? because its the same issue... when i check the fields and click save... the fields still do not appear under string translation

July 2, 2019 at 11:21 am #4126289

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Maybe try increasing the php max input vars to 7000, I have attached a screenshot of the string registered perfectly only local environment using the clone of your site.

Kind regards
Raja

July 2, 2019 at 12:19 pm #4126657

danielK-15

i just made an info.php and saw the server still shows 2500 which is strange but thats why it still not working

July 3, 2019 at 5:27 am #4131863

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please ask your hosting provider to help in this case some times the PHP values are locked in the server settings. Let me know the results once you are able to increase the PHP max input vars limit.

Kind Regards
Raja

July 3, 2019 at 5:56 am #4131921

danielK-15

i was able to solve this issue... thanks so much

July 3, 2019 at 5:56 am #4131923

danielK-15

My issue is resolved now. Thank you!