This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: String translation page in admin loads all strings without pagination Solution: - when you open ST, the url is something like: - wp-admin/admin.php?page=wpml-string-translation%2Fmenu%2Fstring-translation.php - stop the page load and add this after it - &strings_per_page=20 - so it is: - wp-admin/admin.php?page=wpml-string-translation%2Fmenu%2Fstring-translation.php&strings_per_page=20 - now change the value of "Strings pro Seite" to 10 or 20 and leave it like this - leave this page and try opening ST again

This topic contains 4 replies, has 2 voices.

Last updated by michaelB-11 2 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
August 1, 2019 at 9:33 am

michaelB-11

Hi support,

Update from this thread (sorry, didn't have time to further investigate and respond to the old thread): https://wpml.org/forums/topic/string-translation-page-in-admin-loads-all-strings-without-pagination/

The title says it all: The string translation page in the WordPress admin loads all strings without pagination. This obviously makes the whole string translation screen unusable, because the loading never stops (which after a while simply causes the browser to freeze).

I'm not 100% sure after which WPML update this error started, as I didn't used the string translation regularly. But it worked fine before.

Just as additional information: It is the same website I had this issue (also regarding string translation): https://wpml.org/forums/topic/string-translation-not-working-29/

While I don't know if this has anything to do with this new problem, there seems to be something fundamentally flawed on this installation, but I have no idea what or why. I have several websites with WPML and basically the same theme/plugin configuration (without any fancy or exotic plugins or customizations). But this problem only occurs on this website.

UPDATE: I made a copy of the website and deactivated every plugin and switched to the default Twenty Nineteen theme, but the problem persists. So it really seems to be a bug within WPML String Translation. I will now directly attach the Duplicator package, so you can reproduce it.

Thanks and best regards,
Michael

August 1, 2019 at 12:24 pm #4321403

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I am currently downloading the package and will check this on my localhost. I will get back to you as soon as I will have some new/questions!

Regards,
Bruno Kos

August 2, 2019 at 5:01 am #4326877

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I have deployed Duplicator package in my localhost and I see the issue. I have asked our 2nd tier for further information!

Regards,
Bruno Kos

August 2, 2019 at 8:19 am #4327983

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you try this?

- when you open ST, the url is something like:
- wp-admin/admin.php?page=wpml-string-translation%2Fmenu%2Fstring-translation.php
- stop the page load and add this after it - &strings_per_page=20 - so it is:
- wp-admin/admin.php?page=wpml-string-translation%2Fmenu%2Fstring-translation.php&strings_per_page=20
- now change the value of "Strings pro Seite" to 10 or 20 and leave it like this
- leave this page and try opening ST again - does it work?

Regards,
Bruno Kos

August 2, 2019 at 9:08 am #4328361

michaelB-11

Great, that fixed it indeed! Thank you very much for your fast help! 🙂

Best regards,
Michael