Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Lauren 3 years ago.

Assigned support staff: Lauren.

Author Posts
December 8, 2016 at 11:08 pm #1155450

patrizio-romanoD

I am trying to: recently upgraded WPML, String translations, Translation management; all to the latest versions.

URL of (my) website where problem appears: hidden link - a copy where I test any change before replicating on the main website.

I expected to see: normal upgrading.

Instead, I got: /wp-admin/plugin became unreachable because of a 500 error

Steps to duplicate the issue:
First I made a usual upgrade via back end on a bunch of plugins including WPML's, which made the plugin page break on 500 error.
I started deactivating the recently upgraded plugins and found that WPML string translation plugin was causing the issue.
I tried downgrading only this one and let WPML and Translation management on their latest versions, but no luck, as the issue keeps on appearing also this way.

At this moment I cannot make any upgrade on all my WPML plugins on the main website, as it should result in breaking the plugin page.

Thanks in advance for your help.

Patrizio

December 9, 2016 at 2:12 pm #1156070

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I understand you are experiencing a 500 error when you upgrade String Translation. Let's see if we can get a little more info on the error. Please enable the WordPress debug log if isn't enabled already. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Also, I would like you to try a manual update following these steps:
1. Please deactivate all WPML plugins and add-ons
2. Delete the WPML plugins (this will not delete your translations, those are stored in the database).
3. Go to WPML -> Account -> Downloads and download the latest version of WPML core plugin (WordPress Multilingual CMS) and upload it to your plugins file via FTP
4. Activate just the core plugin - do you get any errors?
5. If no errors are shown, go to Plugins ->Add New and click on the Commercial tab. Here you will see the optional add ons for WPML. Start by activating and installing String Translation.

Does the error return?

The topic ‘[Closed] String translation plugin upgrading results in error 500 on /wp-admin/plugins’ is closed to new replies.