Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: String Translation slowing the site

Solution: The was a missing table in the database, adding those manually solved the issue.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 19 replies, has 2 voices.

Last updated by Shekhar Bhandari 2 years, 3 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 24, 2019 at 1:53 pm #4077739

geoclimaS

Hello,
I've found that when String Translation is active, the navigation through my website gets slower. I don't know if it happens only on the backend.
How can I fix this?

June 25, 2019 at 9:25 am #4082681

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I understand you are having site performance issues. Since performance issues depend upon the site, the server, plugins used and furthermore. I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

#1
We recently released new versions of WPML plugins with improvements and fixes. Being so, may I kindly ask you to update the plugin to the latest version, it would also be nice if you can check the problem with the latest version and share with us the results.

BACKUP NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

#2
Can you please review the following articles and see if all the relevant steps are covered?
https://wpml.org/faq/prevent-performance-issues-with-wpml/
https://wpml.org/2012/01/can-your-site-run-faster/

#3
Try disabling and re-enabling all WPML plugins and then going to WPML > Support > Troubleshooting and press the "Recreate ST cache tables" button.

The first visit after the re-activation of the plugins is kinda slow, but after the regeneration of the tables - it will be better.

#4
What type of hosting do you have? Shared, VPS, Dedicated, etc?

#5
Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Thank you for helping us pinpoint the issue. Feel free to add any further information you may have.

Look forward to your reply.

Thanks

June 25, 2019 at 12:45 pm #4084697

geoclimaS

Hello.
#1 plugins are updated
#2 After I have enabled Adjust IDs for multilingual functionality and activated String Translation, got this message: "The site is experiencing technical difficulties. Please check your site admin email inbox for instructions".

June 25, 2019 at 12:59 pm #4084745

geoclimaS

I get the error messare everytime I try to go to the WPML -> Theme and plugin localization page.

June 26, 2019 at 3:22 am #4088513

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It looks like there are some php errors on your site creating that error, could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

June 27, 2019 at 6:09 am #4096857

geoclimaS

After activating String Translation, I tried to go to Theme and plugin localization page and this is what happened.

Cattura.JPG
June 27, 2019 at 9:16 am #4098383

geoclimaS

Migration completed.

June 27, 2019 at 10:20 am #4099041

geoclimaS

Actually, I can't login. All I can see is a blue screen.

June 27, 2019 at 10:22 am #4099049

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Are you trying to log in from here? hidden link Can you please provide a screenshot?

June 27, 2019 at 10:26 am #4099089

geoclimaS

I mean, I can't see the frontend, just a blue screen.
Btw, if I try to go to Theme and plugin localization page, I get this message.

Cattura.JPG
June 27, 2019 at 11:01 am #4099429

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I performed the below steps on the migrated site and the issue seems to be solved.

#1
Updated all WPML plugins to the latest version

#2
Enabled debug.log and noticed wp_icl_strings_packages was missing so created the wp_icl_strings_packages table using the following SQL

CREATE TABLE `wp_icl_string_packages` (
  `ID` bigint(20) UNSIGNED NOT NULL,
  `kind_slug` varchar(160) COLLATE utf8mb4_unicode_ci NOT NULL,
  `kind` varchar(160) COLLATE utf8mb4_unicode_ci NOT NULL,
  `name` varchar(160) COLLATE utf8mb4_unicode_ci NOT NULL,
  `title` varchar(160) COLLATE utf8mb4_unicode_ci NOT NULL,
  `edit_link` text COLLATE utf8mb4_unicode_ci NOT NULL,
  `view_link` text COLLATE utf8mb4_unicode_ci NOT NULL,
  `post_id` int(11) DEFAULT NULL,
  `word_count` varchar(2000) COLLATE utf8mb4_unicode_ci DEFAULT NULL
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;

ALTER TABLE `wp_icl_string_packages`
  ADD PRIMARY KEY (`ID`);

#3
Deleted the untranslated strings from the strings table using the below SQL

DELETE FROM `wp_icl_strings` WHERE `status` = 0

More Details: https://wpml.org/forums/topic/how-to-find-delete-waiting-for-translations-strings/#post-1244576

#4
Went to WPML->Strings Translation->Auto register strings for translation and enable auto-register string for translation.

Being so, could you please check if you can replicate the issue on migration side? If not, you can apply the same changes after creating a backup on your site.

Let me know how it goes.

Thanks

June 27, 2019 at 11:48 am #4099779

geoclimaS

Ok, on migration site it looks fixed.
I'm not sure I understand what I should do now.
Where should I add that sql code?

June 27, 2019 at 11:55 am #4099817

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can perform those SQL changes on your site, please provide me your login details after creating a backup, please make sure to update the plugins to the latest version first and include ftp details as well.

Look forward to your reply.

Thanks

June 28, 2019 at 3:54 am #4104285

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The installed WPML version is 4.2.1 while the latest version is 4.2.7.1, can you please first update all the WPML plugins to the latest versions?

Look forward to your reply.

Thanks

June 28, 2019 at 6:45 am #4104835

geoclimaS

Done but got this message:

Cattura.JPG