We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When String Translation is enabled, the site gets a little slower.

Solution: Please see our documentation for how to increase WPML performance: https://wpml.org/2012/01/can-your-site-run-faster/

Depending on how many strings your site has, this can impact performance a little bit. As a suggestion, you can remove strings that are not translated. To do this, please follow the steps below:

- Click on the WPML > String Translation - Scroll down and look at the "Auto register strings for translation" - Click on the "Edit" button - Uncheck all strings which you do not want to be automatically indexed - Click on the "Apply" button

Also, in WPML > String Translation, you can remove all strings that are not being translated - some you may not even need.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Bruno 1 year, 3 months ago.

Assigned support staff: Bruno.

Author Posts
July 26, 2018 at 10:43 am #2583812

ekaterinaL-3

My website loads very slowly when changing to a different language. Disabling the String Translation plugin seems to make it load quickly again.

When I try and use the Duplicator plugin I get this error:
"duplicator" has been deactivated, it deletes data necessary to manage your site and is not supported on WordPress.com.

I cannot access wp-config.php nor install an ftp because my host is Automattic and they do now support it.

July 27, 2018 at 11:03 pm #2589634

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

Please see our documentation for how to increase WPML performance: https://wpml.org/2012/01/can-your-site-run-faster/

Depending on how many strings your site has, this can impact performance a little bit. As a suggestion, you can remove strings that are not translated. To do this, please follow the steps below:

- Click on the WPML > String Translation
- Scroll down and look at the "Auto register strings for translation"
- Click on the "Edit" button
- Uncheck all strings which you do not want to be automatically indexed
- Click on the "Apply" button

Also, in WPML > String Translation, you can remove all strings that are not being translated - some you may not even need. I'll attach an image for you to see.

Please, let me know if the performance of your site is better after following these steps.

Thank you.