Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.60 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by Bruno Kos 6 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 6, 2019 at 4:26 am

Kristian Adolfsson

This is a continuation of an issue that I can't reply to with the same name.

There has been a number of updates over the last week or so that are targeting speed, both in your plugins and Woo's plugins. It's pretty much getting worse and worse on my old Multisite and the new single install that I give you access to. There are 3 installs on the DO Droplet, one is live (the original Multisite and 2 single installs).

I'm doing the same thing I've done before, control click to open up 5 tabs with Products. First load can be OK with 1-3 sec load time, if I refresh the pages in quick succession with F5, the time go up until I get a record 55 sec for response time, usually I just get a 503 when the server hangs. I've even had to turn off the DO Droplet to get things working again.
As usual when I turn off String Translation plugin I can get donw to .6 sec load time for a Product page, with ALL other plugins activated.

I've turned WPML off completely (and trashed the english pages) on my live site to make it work.

It's not only a problem if I have Woo on the site. We have a multisite with 20 sites, some with WPML and on that install as well, the whole server becomes unresponsive as well for a minute or two. I just control click on a couple of pages to do some simple edits and the server runs out of memory and the CPU is pegged at 90-100% use for minutes.

May 6, 2019 at 10:28 am #3747035

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

I've checked that other thread, so that I don't suggest the same things here.

String Translation can cause slowness on some hosts, especially if String Translation has tens of thousands of strings coming from various plugins that are mostly not used or need no translation. If none of these suggestions work:
https://wpml.org/2012/01/can-your-site-run-faster/
https://wpml.org/forums/topic/how-to-optimize-wpml-performance/

See this - this is what one of our clients did and based on their benchmarks, the site was very fast after this - they even did some direct changes on databases, loaded some strings from mo files instead of database, etc.
https://wpml.org/forums/topic/slow-wpml-performance/#post-3229765

If none of above help, please see this:
https://wpml.org/forums/topic/wpml-drastically-slow-down-my-site-2/page/2/#post-3541827
https://wpml.org/forums/topic/extra-slow-site-after-installing-wpml/

Basically, what I suggested those clients (and it helped) is that they clear database from unused strings and then disable the setting which auto registers strings from new domains. This will however require a certain amount of work.

I've checked:
hidden link

And I can see 35 089 strings inside. Have you translated these and are using these translations? If not, can I suggest this:
https://wpml.org/forums/topic/string-translation-slows-down-page-loading-speed-2/#post-2589634

However, cleaning database from String Translation entries can be done through database much faster:
https://wpml.org/forums/topic/wpml-drastically-slow-down-my-site-2/page/2/#post-3541827

So something on those lines:
https://wpml.org/forums/topic/extra-slow-site-after-installing-wpml/#post-3561281

I know that it might be overwhelming when it comes to links and information presented at once, but performance issues are possibly the hardest ones to fix, since there is a wide array of things that can affect performance and server settings can also have a huge impact - something we (WPML support) have no control of.

Regards,
Bruno Kos

May 6, 2019 at 10:36 am #3747101

Kristian Adolfsson

Hi Bruno

Thanks for the VERY thorough answer. Will look into them. I know my way around a database so we see what I can do.

The other multisite that seemes to be slower and slower could have the same problem with lots of strings. Will check both and get back to you.

May 6, 2019 at 12:22 pm #3748227

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I worked on several String Translation tickets recently and gathered some data from those and also from our clients who tried various things on their own, while this knowledge is also shared among other WPML supporters. So in a nutshell, most important things would be

1) recreate ST cache table (as suggested by George in the other ticket)
2) disable auto register of the new strings
3) remove non-translated strings from String Translation table, using queries such as:

DELETE FROM `wp_icl_strings` WHERE `context` = 'continents-cities';

or

DELETE FROM `wp_icl_strings` WHERE status = 0;

Or perhaps a combination of both, based on the project requirements.

Very few sites have 35000 strings or more of translated strings and those translations used in the frontend/backend, and even if they did, they would most likely need more server resources and possibly more expensive hosting in my opinion.

The other multisite that seemes to be slower and slower could have the same problem with lots of strings

Yes, that would make sense - as the String Translation table if filling over time (this can be due to error in some plugin though, auto registering junk strings, but this is not that often), the whole thing gets slower.

Regards,
Bruno Kos

May 9, 2019 at 3:56 am #3772871

Kristian Adolfsson

Hi Bruno

I've deleted more than 100,000 strings on my different sites so far!!!!

It makes a huge difference.

I have lots of questions that will get to you with today or tomorrow.

For now.

May 9, 2019 at 7:14 am #3773585

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Ok, I am very glad that it works. Hopefully these will be easy questions :).

Regards,
Bruno Kos