Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.66 hours from now. Thank you for your understanding.

This topic contains 38 replies, has 6 voices.

Last updated by Farhad 6 years, 8 months ago.

Assigned support staff: sarah.n.

Author Posts
February 5, 2013 at 9:08 am #102022

Niko

Hi,
I have highly optimised linode 756 running only wordpress. For some reason after installing WPML my page load times became about 4 seconds slower. This is usually the case only with the initial page load for each user if I have w3 total cache on. If I remove the string translation plugin the page is back to it's original speed. I'm even testing this with WP engine at the moment and the same behaviour is there too. Also if I remove w3 total cache the load times for every page are around 4 seconds slower than without string translations.

I tried with the query debug tool and here's the output for wordpress without string translation plugin:
• Total query time: 0.08889s for 110 queries.
• Total num_query time: 0.484 for 112 num_queries.
• » Different values in num_query and query? - please set the constant define('SAVEQUERIES', true);in your wp-config.php
• Page generated in 0.46073s, 80.71% PHP, 19.29% MySQL

And here's with the string translation plugin:
• Total query time: 0.15105s for 123 queries.
• Total num_query time: 3.250 for 125 num_queries.
• » Different values in num_query and query? - please set the constant define('SAVEQUERIES', true);in your wp-config.php
• Page generated in 3.17651s, 95.24% PHP, 4.76% MySQL

For some reason string translations need a LOT of cpu power... Any ideas as to why that's the case and what I could do to cut that down?
I can send the full debug logs if you need.

EDIT: Also both of the settings under string translations are set off which could slow the page down. And the same thing is happening to logged out and logged in users.

February 5, 2013 at 9:29 am #102030

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Niko,

Our developers are aware of this issue and we have an open to-do on our development list.

In the meantime you may find this article of interest: http://wpml.org/2012/01/can-your-site-run-faster/

February 5, 2013 at 9:31 am #102031

Niko

Thanks, I happened to stumble on that link before.

Any idea on when that will be fixed (next release or next year?) and is there any more information available on that bug so I could go bug hunting...?

Thanks,
Niko

February 5, 2013 at 9:58 am #102037

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Niko,

I've passed on your question to our developers. Please stand by for an answer.

February 5, 2013 at 12:26 pm #102078

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Just a small update on this Niko,

It would be good to know how long each query takes (individually ), especially the extra ones that appear when String Translation is on.

If it is difficult for you to see this perhaps you can send us a db dump to use for testing. (I can email you if this is the case so let me know)

Thank you.

February 5, 2013 at 12:28 pm #102081

Niko

The database queries take generally less than 0.005 seconds, usually under 0.0005 seconds. Didn't see any queries over 0.09 seconds.
However as that summary I pasted earlier says, the biggest problem is with PHP, not mysql.

-Niko

February 5, 2013 at 6:57 pm #102199

George

finally, I have been going crazy for 3 days trying to figure out what has turned my website into a snail. It was taking 14-15 sec to load a page with pictures....as long as I know that it was the string translation causing the issue. Hopefully, this will be resolved very soon. Is there anything we can do in the meantime?

February 5, 2013 at 11:16 pm #102224

Philippe

WOW! I have lost a day tracking this one 🙁

I have the WP Super Cache installed, but what I have found is that with the Debug Queries running and the WPML String Translation plugin deactivated I have 0,06501s for 169 queries and 0,930 for 174 num_queries but with the plugin activated the results are quite disturbing:
6,52597ss for 9502 queries and 25,372 for 9510 num_queries.

I have been working at this slow speed for the last 3 days thinking it there was some big hit on the server from other accounts but the problem is coming from the WPML String Translation 🙁

Please fix this!

Can I disable the plugin until I have finish the dev of the site and then enable it to do the translation and then disable it when the translations are done?

Thanks for your help

February 6, 2013 at 1:54 am #102227

George

I used the plugin P3 (Plugin Performance Profiler), which told me that it was the string translation causing the problem

February 6, 2013 at 7:13 am #102249

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

@george:

Is there anything we can do in the meantime?

Yes. check this information: http://wpml.org/2012/01/can-your-site-run-faster/

@philippe

Can I disable the plugin until I have finish the dev of the site and then enable it to do the translation and then disable it when the translations are done?

Yes, you can. Backup your database when the translations are done and before de-activating the plugin just to be sure.

February 6, 2013 at 1:30 pm #102334

George

Hi Sarah,

I'm sure you get this question often, but what kind of timetable are we looking to fix this issue? I am in the process of building a whole new website but I am not finished the translation. If the bug will be fixed in the next coming days, I will wait to launch it, if it will take weeks and possibly months, I might just launch my site only in english.

thank you

February 6, 2013 at 9:41 pm #102444

Mihai

Sent you all an email asking for some information. If you can send it would help us to identify the problem and find a solution faster.

Thank you,
Mihai

February 6, 2013 at 10:14 pm #102446

Niko

Thanks, I sent you the info you requested.
I presume this is a bug you'll be fixing in next release?

-Niko

February 7, 2013 at 12:02 pm #102551

Mihai

Thanks for the info Nikos and George.

Nikos - if you look at the queries list you can see that when String Translation is on, two queries are no included in the report.

⦁ Total query time: 0.15105s for 123 queries.
⦁ Total num_query time: 3.250 for 125 num_queries.
⦁ » Different values in num_query and query? - please set the constant define('SAVEQUERIES', true);in your wp-config.php

Can you try moving that constant declaration?

Also - if you could also send the theme that would be great.

February 7, 2013 at 12:11 pm #102554

Mihai

George, I've tested you database too but the total time for the queries that I get is 0.054291009902954.
This is because I'm using the default theme instead of the actual theme that you are using. Can you please send that along too so my debugging would be more accurate?

Thanks