Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.93 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: When the String Translation plugin is activated website becomes extremely slowб sometimes more than 15 seconds.

Solution: Try an image acceleration or content delivery service.

Please review the following information: Jetpack with Photon: https://jetpack.me/support/photon/ MaxCDN: https://www.maxcdn.com/ Amazon S3: https://aws.amazon.com/s3/? Cloudfront: https://aws.amazon.com/cloudfront/

Also take a look at the WordPress plugin repository for plugins that make setting up the above much easier: https://wordpress.org/plugins/

Here is an outline of the steps: - Install Jetpack and enable Photon module. This is an image acceleration service. - or Use a content delivery service such as MaxCDN or Amazon S3 & Cloudfront. There are existing plugins for all three of these.

At this point the site may need more than a cache plugin especially since it's on a shared hosting account therefore I highly recommend looking into a content delivery service but you can try Jetpack with Photon first to see if that's enough. It's also recommended to test these suggestions to find out which combination and configuration workі best for the site.

This topic contains 12 replies, has 3 voices.

Last updated by jordid-4 3 years, 10 months ago.

Assigned support staff: Tia.

Author Posts
January 15, 2016 at 3:21 pm #789068

jordid-4

Hello,

When the String Translation plugin is activated, my clients website becomes extremely slow, sometimes more than 15 seconds. Turned off, the website works fine. I really need the String Translation for some language differences in German/Dutch. What is the cause that it becomes so slow? Could you help me out?

Thanks in advance.
Jordy

January 15, 2016 at 8:04 pm #789294

Tia

Hello, Jordy. Thank you for contacting WPML Support. I am happy to help you with this.

I see the WP memory limit is already 256M but I wanted to check that both lines are at the top of wp-config.php:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Please confirm.

January 18, 2016 at 2:37 pm #790244

jordid-4

Hi! Did that already, but no difference unfortunately. Any other suggestions?

January 18, 2016 at 5:53 pm #790466

Tia

Since performance issues can be difficult to pinpoint, let's check a few variables and settings to narrow the issue. Please answer as many of these questions as you can. Contact your hosting provider, if necessary.

Please keep WPML & all related plugins enabled while we do these steps:

1. If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps are followed?

2. Can you confirm that the following settings are OFF or disabled:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)

3. Can you tell me more information about the hardware including the CPU?

4. What type of hosting do you have? Shared, VPS, Dedicated, etc?

5. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.

6. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?

W3 total cache + WPML

7. Are you using a cache plugin such as W3 total cache?

8. Make sure Disk caching is disabled.

9. Try disabling the W3 total cache plugin.

Thank you for helping us pinpoint the issue. Feel free to add any other information you may have.

January 19, 2016 at 12:31 pm #791131

jordid-4

1. Did the page chaching with WP Super Cache, since it is free and I don't want to spend money on plugins at the moment. No changes, site seems even a bit slower.

2. Confirmed, everything was disabled already.

3. What exactly do you mean? My personal computer CPU? The website runs on every PC slow with String Translation enabled.

4. A shared type of hosting I guess.

5. I have no idea, since it's my clients server and I only build the website on it.

6. Twenty Fifteen and only the WMPL plugins activated and the website is indeed a lot faster.

7. No I don't use W3 Total cache since it's not free, I installed WP Super Cache instead.

8. Done.

9. Does not apply.

January 19, 2016 at 11:22 pm #791713

Tia

- W3 Total Cache has a free version: https://wordpress.org/plugins/w3-total-cache/ but sometimes the cache plugins can make things worse with certain systems & settings so it really depends. Let's debug without this for now.

- For #3, I was referring to the site's hosting CPU but it is okay if you do not have this information on hand.

Do you mind if I login and take a look? May I temporarily install a plugin called "Query Monitor" (https://wordpress.org/plugins/query-monitor/) to debug the database calls?

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply.

The information you will enter is private which means only you and I can see and have access to it.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If needed, I will be using a plugin called 'Duplicator' (https://wordpress.org/plugins/duplicator) to make a local copy of the website for testing purposes. Once the problem is resolved I will delete the local site. Do I have your permission to move forward with Duplicator?

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

January 20, 2016 at 1:31 pm #792206

mihaB

I'm having same issues with all the latest plugins. string translation hugely drops performance of the site to the state that's not usable...

January 20, 2016 at 1:51 pm #792222

Tia

Thank you, jordid. I will leave the thread open.

mihaB, can you open a new ticket thread so we may debug your issue individually? Many thanks!

January 25, 2016 at 12:37 pm #795565

jordid-4

Hello Tia,

My client is happy to hear about your support, so I can allow you to the back-end of the website. How can I give you the credentials discreet?

Thanks.
Jordy

January 26, 2016 at 1:23 am #796096

Tia

I have enabled the private box.

Reminder:

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

January 27, 2016 at 2:41 am #797187

Tia

Thank you, Jordy. No, FTP is not needed at this time. I will let you know if that changes.

Thank you for that information. I am looking into the issue and will respond shortly after investigating.

January 28, 2016 at 6:59 pm #799176

Tia

Hello, Jordy. Thank you for your patience.

I am done with my assessment and here are the results:

- Enabling & configuring W3 Total Cache made no difference. Sometimes this is the case for shared hosting. I also realized the specific features that were enabled are charged for by W3 Total Cache but you do not have to enable them. Normally, cache settings work well without those enabled. Also, it has to be set up specifically. Here is a good tutorial: hidden link

I have the following recommendations for you to try:

- Install Jetpack and enable Photon module. This is an image acceleration service.

- Use a content delivery service such as MaxCDN or Amazon S3 & Cloudfront. There are existing plugins for all three of these.

At this point the site may need more than a cache plugin especially since it's on a shared hosting account therefore I highly recommend looking into a content delivery service but you can try Jetpack with Photon first to see if that's enough. It's also recommended to test these suggestions out to find out which combination and configuration work best for hte site.

Here are the resource links I mentioned above:

Jetpack with Photon: hidden link
MaxCDN: hidden link
Amazon S3: hidden link?
Cloudfront: hidden link

Also take a look at the WordPress plugin repository for plugins that make setting up the above much easier: https://wordpress.org/plugins/

February 1, 2016 at 2:05 pm #801372

jordid-4

Hello Tia. Thank you for your support. Jetpack did the trick and made the website speed up! Everything is fine now.

Again, thanks for your support, you can close the ticket now.