This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.99 hours from now. Thank you for your understanding.

This topic contains 10 replies, has 2 voices.

Last updated by apiI 2 months ago.

Assigned support staff: Bigul.

Author Posts
August 15, 2019 at 10:29 am #4400249

apiI

Tell us what you are trying to do?

Complete the installation

Is there any documentation that you are following?

No

Is there a similar example that we can see?

There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now but can become a critical issue in the future

What is the link to your site?

hidden link

August 15, 2019 at 2:06 pm #4401379

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 15, 2019 at 2:20 pm #4401553

apiI

For FTP, My bitnami wordpress is hosted on Google cloud which means access to FTP is done by private key. For this reason, I installed file manager inside the admin panel so you can play with the files

August 16, 2019 at 9:09 am #4405581

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and login information. I made a Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

August 17, 2019 at 10:17 am #4409793

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

This issue is happening because of the following reasons. I have set languages in my local copy and also tried a few troubleshooting steps. But the issue is existing. Please check the attached images.

1) Language information is missing in WPML>>Languages>>Site Languages

2) icl_string_pages table is missing in the database

Please share with me the following details for tracking the issue.

1) Please let me know how many secondary languages you were having

2) Have you made any changes in the Database?

--
Thanks!

Bigul

August 17, 2019 at 10:29 am #4409839

apiI

Thanks for the reply,
1- This website has not been into production yet thus we're into the process of developing it therefore, no languages have been added in the past.

2- For the database, I made some changes before in an attempt to resolve the issue. I deleted a key in wp_options which is : wpml_string_table_ok_for_mo_import

I also added this to my functions.php file :

function wpml_fix_missing_icl_tables() {

if( function_exists( 'icl_sitepress_activate' ) )

icl_sitepress_activate();

}

add_action( 'wp_footer', 'wpml_fix_missing_icl_tables' );

August 17, 2019 at 5:41 pm #4410535

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It looks like you have selected English as the default language while setting up WPML. Please check the attached image.

I would like to know which other languages you have selected while configuring WPML.

--
Thanks!

Bigul

August 17, 2019 at 5:57 pm #4410659

apiI

Hello,
Arabic as well

August 19, 2019 at 12:34 pm #4415947

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The issue is existing on my local copy after the initial checks. So checking about the issue with our team now. Will get back to you soon. Please wait.

--
Thanks!

Bigul

August 19, 2019 at 2:13 pm #4416751

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please note, it is working on our local copy after the following steps.

1) WPML Troubleshooting
2) Add the languages to site from WPML>>Languages>>Site languages
3) Then remove the key wpml_string_table_ok_for_mo_import from wp_options table

I have tried the WPML Troubleshooting steps and added the languages on your site. So, please remove the key wpml_string_table_ok_for_mo_import from wp_options table and check the warning is still showing for you or not.

--
Thanks!

Bigul

August 19, 2019 at 2:42 pm #4416939

apiI

My issue is resolved now. Thank you!