This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Itamar 1 year ago.

Assigned support staff: Itamar.

Author Posts
September 19, 2018 at 5:20 pm #2749635

otiums

Hi, the problem is very simple:
- I go to "String Translation" tool
- I translate a string in one of the 5 language I setted up
- I click the Save button
- Refresh the page and che if the translation was been saved: not

I have been using your plugin for many years but it is the first time I test similar behaviour.

I tried disabling all plugins and enabling only WPML plugins but it the same.
I can save any other setting for WPML or other plugins, so I can write the database.

Thank you in advance

September 20, 2018 at 6:40 pm #2753067

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

As a first step of debugging this issue, please update WPML and its add-ons to their latest version. Currently, you are using older versions of WPML. And also please update WordPress itself to its latest version.

If it does not help to solve the issue then, please tell me which string are you trying to translate.
Where can I see this string on your site?
What is the source of this string, is it a string from your theme or a plugin?
You are writing: "Refresh the page and che if the translation was been saved..."
Are you refreshing the front-end page and there the string's translation is not showing?
Does the translation being saved in the Strings Translation section in the back-end?

Thanks,
Itamar.

September 20, 2018 at 10:26 pm #2753362

otiums

Hi,

I updated WordPress and all plugins in a local clone of the site, but it doesn't help.

I tried to translate any kind (and domain) of string in any languages:
- I can see the loading icon when I click the "save" button and it disappears after few seconds;
- the ajax call result is successful and the response is something like "99|Non tradotto";
- now I refresh "String Translation" page (back-end) and check if the translation was been saved: it wasn't.

It is very strange...

Thank you
Matteo

September 24, 2018 at 11:56 am #2760336

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Matteo.

I assume that you also check the 'Translation is complete' checkbox.
Could you please approve this?

To continue debugging this issue, please also perform the following.
I suspect that there is a collision with the theme or another plugin.
If possible get your site into a minimum environment.
Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example).
If it persists, then deactivate all the plugins except the WPML and its add-ons.
Then please check if the problem persists.
If it does not persists so start by activating the plugins one by one and check when the problem comes back. Then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

The topic ‘[Closed] String Translation tool does not save translation’ is closed to new replies.