Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: String translation only works when automatic registration is on. I am experiencing this in the password-protected product page and in the "add to cart" button.

Solution: Try to make the change presented in the errata below.

Relevant Documentation: https://wpml.org/errata/string-translations-are-not-visible-on-the-site-after-a-string-has-been-translated/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by marioC-45 2 weeks, 6 days ago.

Assigned support staff: Radu.

Author Posts
April 16, 2021 at 3:10 pm #8557109

marioC-45

Hi,

String translation only works when automatic registraton is on.
I am excperiencing this in the password protected product page and in the "add to cart" button (which I changed in "Request Sample" in my function.php page)

Thank you in advance.

Mario

April 18, 2021 at 6:18 am #8563573

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Mario,

Thank you for reaching out to the WPML support!

Can you go to WPML → Languages → Language filtering for AJAX operations and enable this option, please?

Also, can you go to the WPML → String Translation area, delete the two strings that you have issues with, then scan the WooCommerce plugin for string through WPML → Theme and plugins localization, then try again to translate the strings through WPML → String Translation area. Just give this a try and tell me how it goes.

Also, can you tell me if this is still happening if you deactivate all the plugins except for WPML and activate a default theme, like Twenty Twenty, please? I just want to make sure that this is not an issue caused by one of the plugins (or by the theme) that you're using.

Thanks,
Radu

April 19, 2021 at 1:12 pm #8572659

marioC-45

Dear Radu,

thank you for your reply.
I did try all the things you told me but the problem is still unresolved.

Best,

Mario

April 20, 2021 at 1:13 pm #8581963

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Mario,

Can you give me access to the dashboard area so I can have a closer look at this, please? The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

April 22, 2021 at 2:36 pm #8602021

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Mario,

Can you try to make the changes suggested in this errata too, please?
https://wpml.org/errata/string-translations-are-not-visible-on-the-site-after-a-string-has-been-translated/

Also, I tried to use the credentials that you send to me but I get a message that the password is incorrect. If the change from the errata is not doing the trick either, can you check the credentials and send them again to me, please?

Thanks,
Radu

April 26, 2021 at 5:58 am #8620065

marioC-45

My issue is resolved now. Thank you! Dear Radu

thank you very much.The problem has been resolved.

Have a great day!

M.