Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by emelieC 5 years, 4 months ago.

Assigned support staff: Yvette.

Author Posts
October 5, 2015 at 9:35 am #717786

emelieC

I have the same issues as the person in this thread:

https://wpml.org/forums/topic/translations-disappearing-from-website-after-update-of-wpml/

I have tried everything from fixing the database to setting wpml for translations.

I would need assistance to get my strings back.

Best regards,

Marcus

October 5, 2015 at 9:36 am #717787

emelieC

Also since I updated, the cart widget in the top of my page is now working as before,

It now takes time to load the content, which was earlier displayed immediately.

October 6, 2015 at 7:40 pm #719131

emelieC

I still need assistance urgently on this... thank you!

October 6, 2015 at 7:59 pm #719150

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello.
I am sorry for the delay in responding to your problem.
I understand that your translations are not showing as they were before the update.

1) Check configuraitons
Sometimes, after updates, we find that certain themes reset the configuration setting in WPML > Theme and Plugin Localisation to :" Don't use String Translation to translate the theme and plugins"

Can you please check that this setting is put to: " Translate the theme and plugins using WPML's String Translation"?

2) System Access
If you confirm this setting and the problem still occurs - Could you please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem? The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

3) Examples
Please provide links where I can see examples of the strings that shold be translated but are not.

Thank you.

October 7, 2015 at 7:42 am #719352

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello.

I was able to spend some time in your system to investigate what might be the problem. Here are my observations and suggestions.

1) Translations
First, it appears as if your SV strings are still in the database but they are currently not accessible to the system. This might be because, previous to 3.2.x , it was possible to set the original language of Strings Translation table to something other than EN.

2) Original language of Strings now EN
With 3.2.x this is no longer possible and the source language is assumed to be EN. In your case, this introduced new EN strings that had no translations assoicated to them into the table.

Going forward, it also means that you must go through your theme/plugin options and edit them in the ENGLISH values...later go and translate them.

3) Going forward
This was a problem for a number of clients that upgraded to 3.2.x from 3.1.9.7

I have consulted with some colleagues and they suggest that we try the following with a snapshot of your system locally OR after a full system backup on your active installation:

1. Deactivate all wpml plugins.
2. Change icl_sitepress_version option to 3.1.9.7
3. Re-activate wpml plugins.

We hope that setting the icl setting to 3.1.9.7 in the DB will change string lang. back to EN. The current version of the plugins now run an upgrade script to handle this situation.

4) System Snapshot
For this I'll need to temporarily install a plugin called "Duplicator" on your site with your permission. This will allow me to create a copy of your site and your content.

If you prefer to do it on your own, you can provide me with the snapshot following these directions:
Duplicator instructions
(1) Instructional Video
hidden link
(2) Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

Once the problem is resolved we will delete the local site

October 8, 2015 at 9:47 am #720337

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Thank you so much for giving access to a test system.

I regret to inform you that the steps suggested did not seem to affect the strings status so it appears that the strings will need to be retranslated.

You might be able to ease the pain by doing the following:
1) Before upgrading, go through all of your theme/Plugin options and change any setting that you currently have in SV to EN. This should then set the string language in the table to EN and the translation on import should not overwrite the translations.

2) You can consider exporting the contexts of your theme/plugins contexts that you have in common with other installations so that they can be imported after upgrade.
For example, if you are using the Woocommerce plugin in another installation you re-use the re-translation effort used on this current site by exporting a .po file of all translated strings from the ringsofsweden.com installation for this context. Then after upgrading the other site, you can import the translated strings to not have to re-translate the Woocommerce again.

I await you comments and questions. I am truly sorry that I could not find a way to make your old translations work in this new environment.

October 28, 2015 at 10:52 am #734435

emelieC

Hello Yvette!

I have come further in the investigation.

One problem seems to be that the site does not recognize the royal theme.
I have the royal theme activated. I go to blogg and search for something. On the top it says "Search results for: ...." I go to string translations to translate it.

The only string it finds is for theme twentyfourteen. So I went ahead and translated it. And the tranlsation shows up on my site.

Very strange. Why does WPML choose the twentyfourteen translations?

Sometimes I see the royal stings but they say (obsolete) and sometime nothing shows up from the Royal theme. I see a lot of strings on the site that need translation, but the ones that are there specificly from the theme, they do not appear for translation. So after the update the Royal theme strings do not appear at all.

I hope you are still with me here.

Thank you!

October 28, 2015 at 3:16 pm #734744

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Aha! I think you have given a key bit of information.
Please allow me to investigate this again.

October 29, 2015 at 12:50 pm #735475

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello.

I would like to try to recuperate the strings as I believe that the problem is linked to the context redefinition of themes/plugin strings (see image).

To do this I would need:

1) Please take a complete system backup
2) Provide a screenshot with istructions on how to see a sample string that i not translated.
3) I will then "fix" this string to see if my steps work.
4) Have you confirm that all is ok

If it works for the test case then we can apply the same steps to all the theme strings.

Thanks you

October 29, 2015 at 3:57 pm #735704

emelieC

Very well!

I have now taken a full backup of the system.

on this blogg post there are some strings:
hidden link

- share post
- posted on
- Comment

Thanks!

Can give you more info on other strings if you need.

Let's do it! 😀

Thank you for still trying to fix this!

October 29, 2015 at 4:00 pm #735706

emelieC

If that does not do the trick, there is some further info on this post:

https://wpml.org/forums/topic/i-get-javascript-errors-when-trying-to-add-all-product-variations-not-saving/

November 3, 2015 at 2:11 pm #738436

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello. Sorry for the long response time.

I manually changed the database status for the theme strings. You will see this in the Strings table that shows "royal" as no longer obsolete.

Can you see if this "worked" to restore the translations?

Please do not scan your theme again as all the manual work will be overwritten.
I am now going to investigate why your theme string are not being scanned.

November 13, 2015 at 6:25 pm #746281

emelieC

Alright,

That sounds great. Actually since I have scanned it earlier, the obsolete stopped showing up. So now I am not sure if I can find so many. I would need to scan again to get all back again.

I am looking forward to your reply. It would be great to have the whole site translated before christmas 🙂

Best regards!

November 16, 2015 at 1:46 pm #747091

emelieC

Hello Yvette,

Do you have any news on this? I'm am really eager to rescan and start making changes.

I guess I would not mind redoing all the translations if I have to. I just need to be sure they are not going to disappear again.

Best regards,

Marcus

November 17, 2015 at 8:56 am #747669

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

No - I am sorry that I do not have more news. I was waiting for your news if the work I did earlier allowed you to recuperate your translations for the Royal theme. Did it?

If your theme strings were recuperated what I would then suggest is to export the existing translations to a .po file using the Strings panel (see image).

Afterwards you can rescan your theme, then re-import these particular strings back into the strings table.

Does this make sense?

ExportTranslationsForLaterImport.png