This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Yvette 1 year ago.

Assigned support staff: Yvette.

Author Posts
September 18, 2018 at 10:40 am

John Hobson

I have sent strings for translation via the translation basket in translation management and assigned them to a translator.

However under their login they are not showing (see screenshot). You can see that the strings have been sent to the translator in the other image.

The 'select which strings to display' dropdown also suggests that there are 154 translations but selecting that option does not show them.

How can I get strings to appear in the list for the assigned translator?

September 19, 2018 at 7:43 am #2747577

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I will be helping you with this. Would you mind also sending me the login credentials for the assigned user?

Or, as an alternative, you may create a new translator id, assign some jobs to them, and then send me those credentials so that I am also able to see the translator view of the dashboard.

I am opening the private area for this additional information.
Thanks

September 19, 2018 at 8:51 am
September 19, 2018 at 10:51 am #2748443

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thanks for the logon. Just to notify you, I set the WPML Admin user as a "Translation Manager" so I could see the outstanding jobs.

I now see the problem clearly.

I will consult with some colleagues here and get back to you as soon as I can.

September 19, 2018 at 10:55 am #2748450

John Hobson

great thanks. 🙂

September 19, 2018 at 11:27 am #2748560

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Well - I learned something today.

Here is the response I received:

"We currently don’t have the option to create a local job for translating strings, so the translator should go to the String Translation module and translate the strings there. You can create a feature request for it."

So, unfortunately I cannot give you any resolution on this issue and only open a feature request. Feature requests are reviewed regularly but there is no guarantee if/when they will be implemented.

Please let me know.

September 19, 2018 at 12:21 pm #2748699

John Hobson

Thanks,

So could you let me know how I can give this user access to the string translations admin page without giving them access to the rest of the WPML options and settings pages?

Thanks,
John

September 19, 2018 at 1:19 pm #2748908

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I did some testing and it appears that if you give assign the user the "Editor" role in their user profile, they can then see the Strings assigned to them for translation.

However, it does also give access to additional menu options (see image). It does not give access to the WPML options. Only the WPM Media Translation interface.

The topic ‘[Closed] String Translations not showing for translator’ is closed to new replies.