Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by melissa 7 years, 11 months ago.

Assigned support staff: Dominykas.

Author Posts
July 16, 2013 at 11:02 am #145302

melissa

Hi,

I have tried to add a few translations in the String Translation module but it is not appearing on my site. I tried to follow some of the other threads of people who had the same problem but it still is not showing up. Could you please help?

July 16, 2013 at 12:12 pm #145337

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Melissa,

Lets see what we can do here - there are several things which could interfere...

# Please make sure that you are using WPML 2.9 and String-Translation version 1.8

# Could you provide me with a screenshot to your "WPML > String-Translation" section, showing the translated strings?
(you can upload it via the "Upload an image" link)

# What is the name of your current theme?
(we might have dealt with it in the past)

Thanks!

July 17, 2013 at 6:19 am #145592

melissa

Hi, just updated my WPML plugins as suggested and delete the cache but still no go. I am using Cheope by yithemes.

WPML share.jpg
WPML string.jpg
July 18, 2013 at 11:19 am #146223

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Melissa,

Thanks - ok, your String-Translation is definitely correct.
Now it would be interesting in what way the theme is localized.

Could you provide us with credentials for your website and we have a closer look?
I will sent you an email with more details in a minute. Thanks in advance!

July 22, 2013 at 12:11 pm #147297

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Melissa,

Just to keep you updated..
Thanks for the credentials and we are checking now more in depth.

July 23, 2013 at 11:55 am #147832

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Melissa,

Quick question - what we see here hidden link is the bottom right corner of your start page, correct?

July 24, 2013 at 7:36 am #148083

melissa

I may not be sure what you mean by a start page exactly, I would have guessed it meant the home page? That is one of my product pages and the share button is for the Chinese soacial media Weibo which shows up on the English page but not the Chinese.

July 24, 2013 at 11:51 am #148207

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hi Melissa,

Exactly, I meant the home page.. and I was wrong - I see it now.

Currently I'm checking the theme file where we the data should appear.
Most likely we have to add a call to our API-Funktion "icl_t".

--
http://wpml.org/documentation/support/wpml-coding-api/
icl_t() fetches a translation from the wpml database table and echos it.

July 30, 2013 at 3:39 am #149852

melissa

Hi Andreas, have you had any luck with resolving this?

July 31, 2013 at 9:18 am #150338

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Melissa,

Sorry could have asked this at the very beginning..
Is your theme this one: http://wpml.org/theme/cheope-shop/ ?

If that is so, could you update your theme to its newest version 1.8.1 ?

Reason being:
Currently you are using version 1.5.1 but the theme was made compatible with WPML from version from version 1.7 onward.

August 9, 2013 at 9:06 am #153283

melissa

I finally finished the update (had to switch to a child version of the theme so that I don't ever have to suffer through the update process again!) but it still doesn't seem to work.

Could you please have another look now that it is a compatible version?

Thanks Andreas!

cheope share the llove english.jpg
cheope share the llove chinese.jpg
August 12, 2013 at 10:12 am #153913

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Melissa,

Thanks for updating+feedback and sorry for the delay!

Your theme is listed here http://wpml.org/documentation/ as "Works OK".
Now and then it happens that theme authors add later small additions after our certification, which are not WPML compatible.

I will notify now our compatibility team to have a closer look at this string and they will also then inform the author to adjust things.

August 13, 2013 at 5:24 am #154170

melissa

Great thanks Andreas!

We were hoping to launch next week so if there is any way this could be looked at (and resolved - fingers crossed!!) asap that would be amazing.

The topic ‘[Closed] String Translations not working’ is closed to new replies.