This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by jamesM-11 2 weeks, 4 days ago.

Assigned support staff: Noman.

Author Posts
September 26, 2019 at 11:52 am #4646435

jamesM-11

I am trying to: make English 'string translations' expressed in Dutch on Dutch pages

Link to a page where the issue can be seen: hidden link

I expected to see: 'Your Name', 'Your Email', 'Subject', 'Your Message' in Dutch

Instead, I got: only the English

September 26, 2019 at 12:41 pm #4646929

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have tried to visit the link that have provided but it redirecting me to login page of your site. Probably you are using contact form 7 plugin to display form on that page and you can translate it by following our step by step guide for contact form 7 translation:
https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

September 26, 2019 at 2:36 pm #4647763

jamesM-11

In following the steps on the video, I got stuck at the translation basket (image 1), because there was no option for me to do my own translation when I followed the instruction to again click on 'translation basket'. On the video it said I could assign the translation to myself, which is my preference, but I only got image 2. Help.

September 26, 2019 at 5:26 pm #4649255

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Could you please make sure your current logged in user is added as a translator from WPML -> Translation Management -> Translation Roles. You can use existing users or create new users to add as translator.

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 29, 2019 at 6:07 pm #4661193

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Could you please go to WPML >> Translations page and press ‘Take and translate’ button and add the translation as you can see in the attached screenshot.

If you have other questions/issues then please create a new ticket for each issue and we would be happy to help. This will help other users with similar problems to find solutions when searching the forum, We do not handle multiple issues in one same ticket as per support policy.
https://wpml.org/purchase/support-policy/

Thank you

October 2, 2019 at 3:06 pm #4681771

jamesM-11

My issue is resolved now. Thank you!