This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Shekhar Bhandari 6 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
March 12, 2019 at 5:27 am #3318537

florianP-4

I am trying to:

I want to use the Advanced Editor to streamline all the translations of future page. But it seems like with the theme/page builder I'm using, it's causing all the html tags class to appear in the editor.
Is there a way to exclude them automatically ? or maybe have an "exception list" ?

Please see the image for reference.
(it's only dummy text for now but the tags & classes shouldn't be here.

Alternatively, is there a way to publish a "in progress" translation so it does appear on the website?

Thank you for your help !

March 13, 2019 at 5:22 am #3329963

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

I think this is happening because you are not adding those tags in HTML format rather than you are adding it in text format and all those formattings are escaped, could you please check if those added texts are added properly HTML format rather then Preview format?

Look forward to your reply.

Thanks

March 13, 2019 at 5:48 am #3329999

florianP-4

Hi. I’m using the page builder that comes with the theme.

March 13, 2019 at 5:52 am #3330069

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The theme builder probably be using HTML preview while creating content, creating the issue, to further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

March 13, 2019 at 10:29 am #3331979

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The FTP details are not working so could you please check it once? You can edit your previous private reply to send updated details if you wish.

Thanks

March 13, 2019 at 8:26 pm #3338103

florianP-4

sorry my bad Shekhar, I sent the wrong server address. I updated it

March 14, 2019 at 8:36 am #3341487

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I can confirm this is a compatibility issue, I have forwarded the details to our Themes & Plugins Compatibility Team and they will contact the author. Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

It would be great if you can also contact the author asking him to reply us. You could also refer them to our Go Global program so that we can help them make their theme compatible with WPML. https://wpml.org/documentation/theme-compatibility/go-global-program/ This may help expedite the process.

We are closing the ticket but we will keep it in our records. You will be notified the moment we have the author’s cooperation in this process.

Thanks

April 1, 2019 at 11:46 am #3507479

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Our compatibility team has provided the workaround, so could you please follow the below steps and let me know if this helps:

1) Copy the following code in WPML->Settings -> Custom XML configuration

<wpml-config>
    <custom-fields-texts>
        <key name="gdlr-core-page-builder">
            <key name="*">
                <key name="value">
                    <key name="title"/>
                    <key name="caption"/></key>
                <key name="items">
                    <key name="*">
                        <key name="value">
                            <key name="title"/>
                            <key name="caption"/></key>
                    </key>
                </key>
            </key>
        </key>
    </custom-fields-texts>
</wpml-config>

2) Once you place the code there, go to WPML->Settings -> Multilingual content setup and refresh the page.

3) Translate the page

Look forward to your reply.

Thanks

The topic ‘[Closed] Strings and tags appear in the Advanced Editor’ is closed to new replies.