Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Strings are not appearing or aren't associated to the right translation

Solution: This issue was happening because of a compatibility/misconfiguration and it worked after the following steps. Please try the following steps for the proper and easy translation of *Accommodation* posts and make sure you are getting the expected result or not.

1) Visit WPML>>Translation Management settings page and choose *Multilingual Content Setup* tab
2) Choose *Use the translation editor* option for *How to translate posts and pages* and save the settings
3) We have to add the following language configuration for each Editor field to show it as Editor field in Translation Editor. Becuase of compatibility issues, it is appearing as a text field.

<wpml-config>
 <custom-fields>
   <custom-field action="translate" style="visual">accommodation_sample_menu</custom-field>
   <custom-field action="translate" style="visual">accommodation_sample_dishes</custom-field>
 </custom-fields>
</wpml-config>

4) Visit *Custom XML configuration* tab of WPML>>Translation Management to add the custom language configuration.
5) Then visit *Multilingual Content Setup* tab of WPML>>Translation Management to refresh the language configuration settings
6) After that translate the Accommodation Post to German & Italian and make sure the bug is existing or not.

Relevant Documentation: https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

https://wpml.org/documentation/support/language-configuration-files/#custom-fields

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by idaL 2 years, 5 months ago.

Assigned support staff: Bigul.

Author Posts
February 7, 2018 at 1:56 pm #1510074

idaL

I am trying to:
My issue is that I created some yacht (accommodation) lists and location lists following the templates of my bookyourtravel theme, but the accommodation tabs and extra fields are not associated to the right translations. I translated them, but they're appearing under other translations.
Let's give you an example: in English I have the accommodation tab "Itineraries" and the description field inside it "Itineraries". In Italian the accommodation tab, for example, is "Water sports" but then the "Itineraries" are appearing under "water sports".
Also I found a list of translations in the string translations I already made that are marked as "English" words, but in fact they're German or Italian! I never inserted some English words in German or Italian. And I cannot even find those words inside of the theme so that I could cancel them...
So I cancelled all the tabs I could cancel and inserted them again, in order to create new translations, but they're not visible inside of the string translations.... :(((
I need to go online in a few days.... and need to solve that... thank you

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

February 9, 2018 at 4:59 am #1512313

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @idal,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please fill the private details fields after a full site backup. Check the following links for more details about our private information sharing. I would like to access admin area of your site for further checking.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

I have a request. Please upgrade the following configuration for the expected performance of your site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Please increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

February 13, 2018 at 3:35 pm #1516448

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Ida,

Thank you for the information. I went through the *Accommodation* posts but not able to reproduce the issue exactly on your site. Therefore please let me know the exact steps to reproduce the issue on your site.

Please note, you can change the language of the string by selecting the string from WPML>>String Translation panel. Please check the attached images for more details.

--
Thanks!

Bigul

February 13, 2018 at 3:49 pm #1516479

idaL

Hi Bigul, thank you for your reply. I will try to change the language then, but the problem is that I never inserted "original" German words selected in English, but the Italian and German strings that are marked as "English" are translations of the original strings (accommodation tabs and location tabs) and should appear as translations and not as original strings. That's the problem... 🙁

Exactly the problem is that when I fill the English tabs with data, the data will be associated to wrong tabs in the foreign languages...

Best,
Ida

February 14, 2018 at 7:01 am #1517084

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Ida,

Thank you for the updates. I have a request. Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

February 14, 2018 at 7:50 am #1517122

idaL

Hi Bigul, of course! No problem. As I told you, also the creator of the Bookyourtravel wordpress template is trying to solve the problem but without result for the moment. He says that probably the wrong strings were created while adding some new accommodation and location tabs in the theme optiona while navigating in the wrong language. He says that „theme options“ should be changed only in the original language which is English.
I don‘t remember if this actually happened, but there should be a way to cancel the wrong tabs/strings and to insert new tabs with a right translation.
But I already tried to do that, I canceled some old categories and added some new ones, but they haven‘t not even appeared in the strings to translate!....

Do you think it would be a good idea maybe to contact the creator of the template and to try to solve it together?
It is „themeenergy“.

Kindest regards,
Ida

February 14, 2018 at 5:59 pm #1518109

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Ida,

Thank you for the details. We have to make sure the compatibility issues first. Then I can forward it to our compatibility team. Compatibility team can work with theme development theme for fixing the issues.

So as a part of escalating procedures, I made a duplicator copy of your site now. Will debug it further on my local server and get back to you. Please wait.

--
Thanks!

Bigul

February 15, 2018 at 4:56 pm #1519456

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Ida,

For your kind information, I am not able to reproduce the issue exactly on my local copy. I have created few Accommodation posts and translated it into German. It is working fine for me. The only thing in the settings is that you have not selected translation preferences to a couple of fields like *accommodation_sample_menu*. Please check the attached images for more details.

I have a request. Please try the following steps for the proper and easy translation of *Accommodation* posts and make sure you are getting the expected result or not.

1) Visit WPML>>Translation Management settings page and choose *Multilingual Content Setup* tab
2) Choose *Use the translation editor* option for *How to translate posts and pages* and save the settings
3) We have to add the following language configuration for each Editor field to show it as Editor field in Translation Editor. Becuase of compatibility issues, it is appearing as a text field.

<wpml-config>
 <custom-fields>
   <custom-field action="translate" style="visual">accommodation_sample_menu</custom-field>
   <custom-field action="translate" style="visual">accommodation_sample_dishes</custom-field>
 </custom-fields>
</wpml-config>

4) Visit *Custom XML configuration* tab of WPML>>Translation Management to add the custom language configuration.
5) Then visit *Multilingual Content Setup* tab of WPML>>Translation Management to refresh the language configuration settings
6) After that translate the Accommodation Post to German & Italian and make sure the bug is existing or not.

Please check the following tutorial for more details.

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

https://wpml.org/documentation/support/language-configuration-files/#custom-fields

If you are still having the issues, please let me know the exact steps to reproduce the issue.

--
Thanks!

Bigul

February 15, 2018 at 7:31 pm #1519588

idaL

Hi Bigul, can I give you a "virtual hug"???? I already thought the problem would exist forever since the creator of the template didn't even figured out what the problem was and not even how to enter my hidden link. Now I followed your steps and everything is working perfectly! Also the strange tab strings in foreign languages marked with the English flag completely disappeared!
You just find perfectly out that those custom tabs were simply not recognized as items to be translated and instead of the translation a crazy duplicate of the original was created... only in a foreign language...
Thank you so much!!
Kindest regards,
Ida