This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Orly Shafir 8 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 30, 2019 at 3:09 pm

Orly Shafir

I am trying to: Translate string on my site

This is a minisite in a multi-site installation, the main site translate just fine

I expected to see: The "search" in Hebrew and other string that I already translated

Instead, I got: It looks like WPML does not recognize the language and does not translate anything at all.

September 30, 2019 at 3:14 pm #4665887

Orly Shafir

To access the dev site you will need the extra password, see below.

[content removed]

September 30, 2019 at 9:36 pm #4667585

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for contacting WPML Support. This seems to be a theme compatibility issue. In these cases, these are the procedures:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

September 30, 2019 at 9:59 pm #4667671

Orly Shafir

I did it,
It seems that the problem does not exist on your install with my theme,
So what else can cause the problem?

You can see that in your install the "search" box is being translated.

Any idea's?

September 30, 2019 at 10:10 pm #4667679

Orly Shafir

We also did a test with no plugins installed on our dev server and the problem persist,
The site works fine when WPML is turned off and as soon as we turned it on it seem that it puts the strings in English,

like: The search bar is in Hebrew as it should be but as soon as we turn WPML on it switches to English,

The theme is a custom made theme and we can not seem to find any problems in the PHP log or anything, its also a very simple one.

We had a very bad experience with WPML support in the past, things drag for a long time and never really get solved, we really ask for your help ASAP as we would like to move the site live.


October 1, 2019 at 4:37 pm #4674031

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for the details. I've just checked your website again and I don't see the issue anymore, did you try anything on your own? I see the search text is translated properly in both english and hebrew as you can confirm at:

1 - English: hidden link (see attached screenshot: customer_english_screen)

2 - Hebrew: hidden link (see attached screenshot: customer_hebrew_screen)

Do you see the same results on your side? Please, let me know, have a nice day.

October 1, 2019 at 6:19 pm #4674651

Orly Shafir


I removed WPML string translation and installed LOCO translate and the problem is fixed,

Thanks, it works fine for now.

October 1, 2019 at 7:37 pm #4675107

Orly Shafir

My issue is resolved now. Thank you!