This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Diego Pereira 1 year, 1 month ago.

Assigned support staff: Diego Pereira.

Author Posts
September 3, 2018 at 3:36 pm #2700280

tessvs

Hey,

After translating pages, the strings are not updated and still show that those texts are not translated even though they are. Also, I would like to translate per page, but this page keeps showing up instead of the original document (please see screenshot). How can I fix these issues?

Greetings,
Tess

September 4, 2018 at 6:06 pm #2704331

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @tessvs, welcome to the WPML support Forum!

This is the translation screen. You must fill in the fields on the right with the translation of the strings and mark the field "The Translation is Complete". After translating all fields, they will appear on your website.

If you prefer to use the manual editor (instead of the translation editor), you can modify this in WPML > Settings> How to translate posts and pages

If you need more help just let me know.

All the best,
Diego

September 4, 2018 at 7:08 pm #2704496

tessvs

Hi Diego,

I was working with the Manual Editor but for some pages the translation screen (as shown on the screenshot) showed up. So for some pages, the normal page showed up which English content I could copy and then translate to Dutch.

Also, when activating String Translation, all the labels I translated with Loco Translate go back to their original content. How can I fix this?

Greetings,
Tess

September 5, 2018 at 2:04 pm #2707495

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please check WPML > Settings > How to translate posts and pages. There is a option to enable/disable the manual editor.

Regarding the Loco Translate, I think there is a conflict with WPML. Please go to WPML > Theme and plugins localization > Localization options and set it to Translate themes and plugins using WPML's String Translation and always load .mo files as backup

If you need more help just let me know.

Kind regards,
Diego

September 13, 2018 at 1:30 pm #2731687

tessvs

Hey Diego,

The developers of the Bridge theme told me that there is a conflict between Loco Translate and WPML String Translation. That means that I loose all the content I translated with Loco Translate when I use String Translation... I would love continuing translating my webshop to Dutch but this is causing problems as I will have to do double work.

How can I translate all the content on my webshop to Dutch while keeping my translations in Loco Translate?

Greetings,
Tess

September 13, 2018 at 7:38 pm #2732819

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

If you are able to export loco translate translations to a .mo file, you could then import them using WPML. To do this, once you have the .mo file, you can go to WPML -> String Translation. At the bottom of the page is a section where you can import the .mo files and assign them to any existing text domain, or create a new one.

Please let me know if it worked for you.

Kind regards,
Diego

September 15, 2018 at 2:30 pm #2737845
tessvs

Hi Diego,

Thanks. The problem is that I also changed labels in English. For example, I changed 'Out of Stock' to 'Sold Out'. However, I don't know how I can change these labels. How can I use these strings for my webshop when I activate WPML String Translation?

Thanks again.

Greetings,
Tess

New threads created by Diego Pereira and linked to this one are listed below:

https://wpml.org/forums/topic/split-modify-string-of-original-language/

September 16, 2018 at 11:44 am #2738831

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

As this is a different issue, I will open a new ticket for this new one.

I will reply in the new ticket.

Kind regards,
Diego