This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Riffaz 7 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
February 23, 2019 at 2:36 am #3234591

eiichiK

Tell us what you are trying to do? The scan for strings have never stopped.

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site? My website hasn't published yet.

February 24, 2019 at 3:28 am #3236207

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This is may be because your theme has too many strings.
If you think this might be an issue just enable the WP Debug and rescan again.
If it is an issue you will see some readable errors on the screen or debug.log
Please refer: https://wpml.org/documentation/support/debugging-wpml/

Also,
Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

Regards,
Riffaz.

February 27, 2019 at 12:23 pm #3250061

eiichiK

I finish Chinese translation but I can't open Chinese page. How can I fix this?

February 27, 2019 at 2:47 pm #3250869

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

I finish Chinese translation but I can't open Chinese page. How can I fix this?
- is this something related to your initial question of this ticket?
- anyhow, enable the WP Debug mode and check
- follow the steps: https://wpml.org/documentation/support/debugging-wpml/

let me know the error messages you are getting after this.

February 27, 2019 at 3:28 pm #3251150

eiichiK

Sorry, I couldn't find how to open the new ticket.
I did define('WP_DEBUG', true);
However, same error message. I think the translation is finished but there is no Chinese file. There is on the list of Chinese pages though.

February 28, 2019 at 8:09 am #3254041

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

I did define('WP_DEBUG', true);
- did your check your debug.log file in your /wp-content/ folder ?

February 28, 2019 at 2:52 pm #3255954

eiichiK

Please check hidden link
I can see Japanese in the footer on PC, but not on iPhone. And still "Bad request" when click Chinese.
Please fix this.

March 1, 2019 at 10:57 am #3259796

eiichiK

Here is debug.log

[01-Mar-2019 09:26:55 UTC] PHP Notice: Trying to get property of non-object in /hermes/bosnacweb04/bosnacweb04ar/b2825/apo.cros55/wordpress/wp-content/plugins/wp-smushit/core/class-wp-smush-admin.php on line 140
[01-Mar-2019 09:28:12 UTC] PHP Notice: Trying to get property of non-object in /hermes/bosnacweb04/bosnacweb04ar/b2825/apo.cros55/wordpress/wp-content/plugins/wp-smushit/core/class-wp-smush-admin.php on line 140
[01-Mar-2019 09:53:29 UTC] PHP Notice: Undefined index: file in /hermes/bosnacweb04/bosnacweb04ar/b2825/apo.cros55/wordpress/wp-content/plugins/query-monitor/dispatchers/WP_Die.php on line 46
[01-Mar-2019 09:53:29 UTC] PHP Notice: Undefined index: line in /hermes/bosnacweb04/bosnacweb04ar/b2825/apo.cros55/wordpress/wp-content/plugins/query-monitor/dispatchers/WP_Die.php on line 46
[01-Mar-2019 09:53:35 UTC] PHP Notice: Undefined index: file in /hermes/bosnacweb04/bosnacweb04ar/b2825/apo.cros55/wordpress/wp-content/plugins/query-monitor/dispatchers/WP_Die.php on line 46
[01-Mar-2019 09:53:35 UTC] PHP Notice: Undefined index: line in /hermes/bosnacweb04/bosnacweb04ar/b2825/apo.cros55/wordpress/wp-content/plugins/query-monitor/dispatchers/WP_Die.php on line 46
[01-Mar-2019 10:51:10 UTC] PHP Notice: Undefined index: HTTP_HOST in /hermes/bosnacweb04/bosnacweb04ar/b2825/apo.cros55/wordpress/wp-content/plugins/wp-fastest-cache/inc/cache.php on line 325
[01-Mar-2019 10:51:10 UTC] PHP Parse error: syntax error, unexpected '[' in /hermes/bosnacweb04/bosnacweb04ar/b2825/apo.cros55/wordpress/wp-content/plugins/wpdatatables/config/config.inc.php on line 65

March 3, 2019 at 4:13 pm #3266429

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Could you please all the non-wpml related plugins and check this.
Especially disable 'wpdatatables' plugin and check this.

Let me know how it goes.

Regards,

March 4, 2019 at 12:48 am #3266732

eiichiK

I did deactivate all non-wpml related plugins and open the translation page and saved it again. But the translation page still never show. It goes "Bad Request".

March 4, 2019 at 6:58 am #3267268

eiichiK

I made a new page and came out the same.
It seems I can't make the translation page anymore.
Please advice ASAP.

March 4, 2019 at 12:56 pm #3268721

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

could you please change the URLs to this hidden link and check this issue?

Let me know.

Regards,

The topic ‘[Closed] Strings in the themes’ is closed to new replies.