This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 10.08 hours from now. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by hanneK 1 month ago.

Assigned support staff: Noman.

Author Posts
September 15, 2019 at 11:37 pm #4575501

hanneK

I am trying to: translate phone numbers in widgets to add country code

Link to a page where the issue can be seen: hidden link and hidden link

I expected to see: +45 added in front of phone numbers of team members

Instead, I got: just the same phone number (without +45) as on the danish page hidden link

I use widgets in the page builder and the jobtitles translates fine, but nothing happens with the phone number

September 16, 2019 at 8:15 am #4577327

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 17, 2019 at 4:33 am #4585549

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for login details. I have fixed this issue by using our XML method and added the following XML code:

<wpml-config>
    <admin-texts>
        <key name="widget_grve-widget-contact-info">
            <key name="*">
                <key name="phone" /></key>
        </key>
    </admin-texts>
</wpml-config>

In WPML >> Settings >> Custom XML Configuration section and now phone field showing correct translation at frontend.

Thank you

September 17, 2019 at 5:30 am #4585631

hanneK

Great. Thank you.

September 17, 2019 at 7:51 am #4586141

hanneK

My issue is resolved now. Thank you!