This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Radu 3 months ago.

Assigned support staff: Radu.

Author Posts
April 9, 2019 at 12:43 pm

johnS-30

I am trying to:
Translate strings in templates from Swedish to English. It has been working before, but doesn't anymore. Unfortunately I don't know when it stopped working. Content is however being translated as expected.

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
For example, the button with the label "Boka" should be called "Book" instead.

Instead, I got:
Swedish strings instead of English.

April 9, 2019 at 1:48 pm #3567527

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey John,

Thank you for reaching out the WPML support!

If this part worked once, it should always work. So let's find out what's changed.

First of all, can you check the dashboard account you send to me, please? I tried to use it but I get a message that the password is not the correct one.

Thanks,
Radu

April 9, 2019 at 2:01 pm
April 10, 2019 at 7:07 am #3572967

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey John,

Thank you for sending me the right credentials. I managed to access the dashboard area but I couldn't find the place where this Boka part of the header is controlled from. Can you tell me how this button is created? I want to check that section and see how can it be translated.

Thanks,
Radu

April 10, 2019 at 7:12 am #3573011

johnS-30

"Boka" is just an example of a string in the templates that isn't translated. None of the strings in the templates is being translated anymore.

<?php
_e('Boka', 'funas');
?>
April 11, 2019 at 11:02 am #3586465

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey John,

Before moving on, please update the WPML and String Translation plugins to the latest version. Also, can you deactivate all the plugins for optimization or caching too, please? There's a chance that the text is not translated due to the changes made by these plugin and this is why I'm asking you to deactivate them for a little.

Thanks,
Radu

April 12, 2019 at 8:18 am #3596163

johnS-30

Sure, I've done that now. WP Super Cache and Autoptimize is deactivated. But I've tried it locally to and it doesn't work. Neither on a new site in the same network with a default theme.

April 16, 2019 at 1:01 pm #3622209

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey John,

I checked all the options several times and, even though thing are looking fine, I still cannot make the strings show in the frontend. In this case, is there any chance that you could send me an archive of the theme so I can check it out and see if I can replicate this issue on a clean install, please? I didn't forget about this ticket but I checked everything I could in the meantime, trying to find out why is this happening.

Thanks,
Radu

April 16, 2019 at 1:52 pm #3622595

johnS-30

Sure, can you make my next reply to one of those where I can upload files? 😉

April 16, 2019 at 4:13 pm #3623949

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey John,

I set the next message to be private so you can safely send me the theme archive.

Regards,
Radu

April 17, 2019 at 5:51 am
April 20, 2019 at 6:38 am #3649541

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey John,

Can you tell me if theme you're using is a custom one, please? I'm asking this because I tried to use the archive you send to me but I want to test the theme separate. I could see that the theme name matches your website name and I couldn't find any info about this theme over the internet. I just want to know if I can simply copy it to my site or if I need any additional plugins to make it work.

Thanks,
Radu

April 23, 2019 at 5:58 am #3659703

johnS-30

Yes it's a custom one. Well, it's based on a Foundation theme, but I consider it to be custom. I believe ACF is the only plugin (besides of WPML) that has to be active.
But I don't think it's theme related. I've tried switching to a standard Twenty[something] theme and the problem remains when I add strings to the template files that should be translated.

May 2, 2019 at 8:11 am #3722633

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey John,

Have you made any progress in the meanwhile? I'm asking this because I was trying to replicate this issue on my local installation in the last few days but now that I checked your website again, I can see that the strings are translated fine when changing the language. Did you find the source of the problem?

Thanks,
Radu

May 2, 2019 at 1:56 pm #3725155

johnS-30

Hi! No, I haven't done anything. But you're right, suddenly it was working. Most of the strings at least. But when I logged in and edited a string and saved, they where gone again... =/