This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Dat Hoang 3 years, 3 months ago.

Assigned support staff: Dat Hoang.

Author Posts
June 11, 2016 at 11:18 pm #907777

hanya-3

I am trying to: make the other language in Arabic but there are some of strings still appear in English although it translates already in string translation

URL of (my) website where problem appears: hidden link

I expected to see: to see Arabic (the other language)

Instead, I got: English

Please Help as soon as possible

June 13, 2016 at 11:50 am #909085

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello, Hanya.

Thank you for contacting the WPML support forum.

Could you lease elaborate on how you have created this 'SEARCH OUR INVENTORY' form?
Did you use a plugin for that?
When you translated those strings in Strings Translation, did you see that you are translating those strings under the correct text domain?
Could you also attach screenshots from the Strings Translation backend of the site where you say that you have translated the strings?
I also like to ask you to share your Debug information with me.
http://wpml.org/faq/provide-debug-information-faster-support/
The debug info can also help a lot in understanding your site structure and configuration so I can better help you.

Thanks,
Itamar.

June 15, 2016 at 8:30 am #912943

hanya-3

Sir Thanks
- Search that im using a part of inventory management system that is a breeze to setup and customize for vehicle inventory.
It also includes a completely customizable, filterable, and sortable Inventory
Search to search Vehicle Listings.
- and yes im sure that im using translating those strings under the correct text domain.
- attached the word 'Transmission' translated via all domains but not appear in search.
- also the other problem sir, that in second language search appears the two languages .
Please sir if not you mind i can provide the user and password for dashboard coz really im stack in big problem here in my work .
Thanks agian

June 15, 2016 at 11:00 am #913334

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hanya, thanks for the info that you have shared with me.

For your request, please read the following:
If you agree, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue.
You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

If you prefer to do it on your own, you can provide me with the snapshot of your website following these directions:
If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.
Duplicator instructions
- From WordPress plugin page, look for “Duplicator” and install it.
- Once installed, you get a new item in the main menu “Duplicator.”
- Chose “Packages.”
- Click on the first button you find in the toolbar on the right (“Create Package”)
- Give it a name or leave it as is
- Click on “Create Package Set.”
- Wait until the package is ready
- Click on “Installer”, then on “Package”: the first one is just a PHP script, the second one is a zip file containing everything you need
- Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big).
***********************
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won’t be able to log in.
You may delete the new admin account once the snapshot has been built.
***********************
Once the problem is resolved, I will delete the local site.
***********************
IMPORTANT: Be sure to take a complete backup of your site and database first before you proceed!
***********************
Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please, could you provide me the additional Info and as well permit me to perform the required steps?

Thanks,
Itamar.

June 15, 2016 at 11:01 am #913335

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Privet message is enabled now.

June 16, 2016 at 9:42 am #915164

hanya-3

Thanks Very much sir
- the problem is about [listings] can`t translated to the other language (Arabic) and this problem makes search not working .
- here`s the ftb,mysql and dashboard feel free to work no problem and i have packup.
again thanks very much u will save me .

June 16, 2016 at 1:41 pm #915656

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Dear, Sir.

Please for your website security do not post sensitive information that can jeopardize your website in a public reply.
You should only use privet replies.
I've deleted the credentials that you have shared with me from the above response and saved them with me.
I'll use those credentials for now but if you want to be on the safe side you better change those credentials and share the new ones with me in the privet message that I'm enabling again now.

Thanks,
Itamar.

June 16, 2016 at 7:32 pm #916177

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello, Sir.

I was checking your website today.
I saw that you were using Visual Composer.
Did follow the instructions for how to use WPML with Visual Composer and page builders when using it with WPML?
You can read about it here:
https://wpml.org/2014/06/use-visual-composers-page-builders-wpml/
I used the method described in that article on your home-1 page.
I also noticed you haven't installed the translation management module of WPML.
I've installed this module for you.
It is essential to have it when translating custom post types and fields.
You should also know that the minimum requirements for your site's installation were low.
The WP Memory Limit was 40MB and through the wp-config.php, I've increased it to 256MB.
Please follow this link for a detailed documentation:
https://wpml.org/home/minimum-requirements/
http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
All of the above still did not fix the problem.
I think that the problem is coming from the fact that the 'Automotive Listings' plugin is completely out of date and needs to be updated.
You have installed version number 4.7, and the latest version is 9.1
I could see from the plugin's changelog that a few WPML fixes were added after the version you currently have.
Is it possible for you to update this plugin?

I look forward to your reply.

Thanks,
Itamar.

June 17, 2016 at 5:07 pm #917654

hanya-3

Hello
Now i updated 'Automotive Listings' , but still same issue, sorry but can you check it now...
Thanks

June 18, 2016 at 9:57 am #918139

Dat Hoang

#1,
I'm working on this ticket.

I can check your site but I don't see any credentials.

Can you please send them in your private reply, then I can check?

#2,
Please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

June 20, 2016 at 8:29 am #919157

Dat Hoang

#1,
The credentials in this case include both WordPress and FTP access info. WordPress is fine but there's no user and password for FTP. Please update your credentials in the previous private reply.

#2,
Thanks for your info.
This page hidden link currently does not have the search box like your screenshot in the first post, can you please check again?
And please let me know how you configure to display it?

#3,
Can you please send the theme/plugin in your next private reply? I'd like to replicate and troubleshoot the issue in my testing site.
NOTE:
- You should use a storage service (like Google Drive, Dropbox...) and send the link in the reply.
- Check again and send me the latest version of theme/plugin.

June 20, 2016 at 8:31 am #919169

hanya-3

Hi sir,
any updates ?
Thanks

June 20, 2016 at 8:33 am #919171

Dat Hoang

Another worth note:
* In your screenshot hidden link , it's "Transmission" (single noun)

* In WPML > String Translation hidden link , there are just "Transmissions" (plural noun)

Basically you still need to translate the string "Transmission" (single noun) somewhere else.