Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by gvidoD 3 years, 2 months ago.

Assigned support staff: Ricardo Alday.

Author Posts
October 30, 2018 at 11:56 am



I am using Strong Testimonials plugin, which is listed as supported from wpml side.

Currently, i have an interesting issue, I have translated success message through string translation. Everything is working and translating correctly when i submit reviews while i am logged in as admin. But when i am logged out or viewing page through incognito, then for some reason strings are not translated correctly in other languages.

I have to mention that it feels like Latvian translation is "stuck". The base language is English and i wrote success message in English. Translated it to Latvian and Russian, but Latvian translation is showing up in all languages (english, russian, latvian). But workin correctly when logged in as admin.

October 31, 2018 at 6:53 pm #2867228


Hello there,

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

Please, what steps should I follow to see the problem? I've tried finding this on your site, but I do not know exactly which link/page you're talking about.

Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

November 1, 2018 at 11:39 am #2868701


Hi! thanks for the reply

Sorry, my bad, here is the detailed information.

So here is the link, lets use russian page as example hidden link

Fill out the form, submit it, you will see success message (thats a strong testimonial plugin)

If you are NOT logged in to the admin panel, then you will see success message appearing in LATVIAN. Its like that in all languages (see first screenshot)

Now if you log in to the admin panel, and submit review through the same page, you will see success message in russian, which is correct. (see second screenshot)

This applies for ENG version as well.

The success message has been entered in to the plugin settings in ENG (see third screenshot) , and translated accordingly (see forth screenshot)

So weird thing here is that it is translated from English to Latvian and this translation is used IN ALL languages when you are not logged in as admin, but translations are correct when you are logged in as admin

hope it makes sense

Screen Shot 2018-11-01 at 13.12.59.png
Screen Shot 2018-11-01 at 13.22.00.png
Screen Shot 2018-11-01 at 13.19.34.png
Screen Shot 2018-11-01 at 13.20.13.png
November 1, 2018 at 9:35 pm #2870038



Thank you. Following the steps you posted above I can see and replicate the problem.

Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

November 2, 2018 at 8:27 am #2871170


Hi Bruno!

Go ahead! Do what you need to do and let me know how to solve it, first time encountering this kind of issue. I checked the DB and it looked fine one the quick glance

November 2, 2018 at 10:53 pm #2873120

Ricardo Alday


Bruno is off for the day.
I tried to install the Duplicator plugin but unfortunately, your server does not meet the requirements to use it.
However, I tested the issue while logged out and could not reproduce the issue.
I recorded a screencast to show you: hidden link

My guess is that it was a cache issue.

November 3, 2018 at 6:32 pm #2874026


My issue is resolved now. Thank you!