This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Dennis 3 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
June 21, 2019 at 4:44 pm #4068563

bernardoC-6

I am trying to: get the translated strings to show up. It's working fine on dev site but not on production.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link
(strings translated)

Instead, I got: The original strings

Hi there!

Something messed up the string translation and I can't figure out what it was. Everything was working perfectly until a couple of days ago when I stopped seeing the strings translated. On the dev site things are working nice still.

The red arrows in the screenshot are pointing to strings that were (and are) translated with WPML string translation.

Any help is appreciated.

Thank you.

June 24, 2019 at 6:11 am #4074815

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.
Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then try to search for the strings again in WPML > String Translation and translate them completely.

Does it help? Please let me know.

Kind regards,
Dennis

June 24, 2019 at 2:11 pm #4077905

bernardoC-6

Hi Dennis!

Thank you for your reply. I did as you suggested but the issue persists.

All strings are showing as 'translation complete' but showing the original language in the frontend.

Please note that all was working nicely a few days ago and is working also nice in the staging environment. For some reason that I'm unaware of the strings stopped showing as translated a few days ago on the live website.

Can you please advise further? I've already granted admin access to one of your colleagues in a previous post in private note. Feel free to use those credentials to access the dashboard.

Thank you!

June 25, 2019 at 6:14 am #4081529

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I run the 'Recreate ST DB cache tables' routing from WPML > Support > Troubleshooting and it seems to resolved the issue. Could you please confirm if the issue is resolved at your end?

Thank you.

Kind regards,
Dennis