This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Bigul 3 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
June 26, 2019 at 11:22 am #4091919

carmanL

I have some translated strings that are not showing on the website.

The English translations are not showing on the website.

These are the two pages that the translated strings are not showing.

hidden link
hidden link

I expected to see the translation from Japanese to English.

Please advice.

Thanks.

June 26, 2019 at 3:31 pm #4093669

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Recreate ST DB cache tables

--
Thanks!

Bigul

June 27, 2019 at 3:37 am #4096389

carmanL

I have followed the steps you told me but the issue still exists.

Please advice.

Thanks.

June 27, 2019 at 9:02 am #4098183

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

June 28, 2019 at 1:40 pm #4107801

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. This may be happening because of the sync issues. I have a request. Please try the following steps after a full site backup and let me know your feedback.

1) Upgrade to the latest version of Divi theme
2) Activate Divi Builder plugin
3) Open the Project post for edit in Japanese
4) Click on *Return To Default Editor* link on the top
5) Update the Japanese Project Post after minor edit using Divi Builder to refresh the translation settings
6) Open the Japanese Project Post translation for edit in WPML Translation Editor
7) Check the missing strings are listing for translation or not

Please check the attached images for more details.

--
Thanks!

Bigul

July 3, 2019 at 7:25 am #4132613

carmanL

Still not working.
Tried to activate the Divi Builder plugin but failed.

Please advice.

Thanks.

July 3, 2019 at 12:40 pm #4136455

carmanL

Just found out that the theme we are using already includes the Divi Builder, so the Divi Builder plugin has been deactivated.

I have followed the steps you told me, but still no luck and the contents now are gone.

Please advice.

Thank you.

July 3, 2019 at 1:37 pm #4137031

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please share with me the WordPress debug.log (not WPML debug information) for more details.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug(visit hidden link page) and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

July 5, 2019 at 3:32 am #4147317

carmanL

Here is the link you needed.

https://pastebin.com/Jt3XLj2C

Thanks.

July 5, 2019 at 6:27 am #4147921

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the Debug log details. But it is not showing any warning or error related to WPML. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

July 5, 2019 at 9:33 am #4149671

carmanL

I have installed the Duplicator plugin.

Thanks.

July 6, 2019 at 6:28 am #4155081

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. The Duplicator free version is showing *Host Build Interrupt* error while creating Duplicator package. The result was the same after trying different settings.

Then I have tried with Duplicator pro plugin and it works. But not able to download the Duplicator Archive file because of the *Failed - Server problem* issue. Please check the attached images for more details.

Therefore please share me your FTP credentials. I have enabled the private option for the next reply.

--
Thanks!

Bigul

The topic ‘[Closed] Strings translation not showing’ is closed to new replies.