This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 1 voice.

Last updated by dariaS 1 week, 6 days ago.

Author Posts
October 8, 2019 at 9:42 pm

dariaS

I am trying to:
Switch languages on the Woocommerce checkout page.

Link to a page where the issue can be seen:
hidden link

I expected to see:
The card fields remain the same.

Instead, I got:
Instead the height of the card input fields is reduced and the fields become unusable.
I have tried clearing the site and browser cache; also tried deactivating and reactivating all WPML plugins.
The only way to fix the issue seems to be to disable Stripe Credit Card Payments in Woocommerce>Settings>Payments, click "save", and reactivate the Credit Card Payments options in Woocommerce settings again.
This is only an issue in Chrome (Firefox, IE do fine for me). I have tested on PC and iOS and get the same results.

October 9, 2019 at 5:52 pm #4725001

dariaS

The issue was with the host optimization plugin - nothing to do with WPML. Thank you anyway!