Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: My woocommerce site accepts GBP (default) EUR and USD.

I recently found that the option at checkout to pay via Stripe when USD is the chosen currency has gone.

Solution: Go to WooCommerce multicurrency settings and re-add Stripe credentials, save.

The client eventually used another plugin for Stripe payments.

Relevant Documentation: - https://wpml.org/documentation/related-projects/woocommerce-multilingual/multi-currency-support-woocommerce/

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by rufusB 4 months ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
September 22, 2020 at 5:35 pm #7072177

rufusB

My woocommerce site accepts GBP (default) EUR and USD.

I recently found that the option at checkout to pay via Stripe when USD is the chosen currency, has gone. This is true in all of the three site languages. Subsequently it appears Euros payments don't work either, while the GBP still works. I have had to disable all secondary currencies.

I checked this using twenty twenty theme and disabled all but six necessary plugins (woocommerce, woocommerce stripe gateway, 4 WPML plugins- woocommerce multi-lingual, multilingual CMS, String translation, tramslation management ). Same result.

The gateways are set up according to https://wpml.org/documentation/related-projects/woocommerce-multilingual/multi-currency-support-woocommerce/

September 23, 2020 at 8:14 am #7077245

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

Would you mind updating WPML plugins to the before we resume checking this out?

Also, did you try checking this when WPML is deactivated? That may answer if this is in fact gateway problem itself and not related to WPML.

However I suggest updating our plugins first, also make sure to update WooCommerce and all its related plugins to the latest versions. Let us know about your findings!

Regards,
Bruno Kos

September 23, 2020 at 10:24 am #7078463

rufusB

Hi Bruno,
Thanks for getting back. I've updated the WPML plugins and also Woocommerce as far as these are available from Word Press. The problem persists.

I can't test this without WPML as WPML is integral to multi-currency function.

Regards,

Rufus

September 24, 2020 at 11:35 am #7090323

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello Rufus,

thanks for getting back.

Can you please enable multi-currency mode and check that the correct payment gateway (Stripe) is enabled for each currency.

Then please for each currency remove and add again Live published key and the Live secret key. Make sure they are the correct one and added to the correct field. Example image attached.

Similar ticket issues:
- https://wpml.org/forums/topic/woocommerce-stripe-payment-gateway-is-not-working-with-multi-currencies/page/2/
- https://wpml.org/forums/topic/stripe-gateway-unavailable-when-viewing-custom-language/page/2/

Please let me know how it goes and if it helps fix your issue.

Kind regards,
Drazen

September 24, 2020 at 12:49 pm #7091443

rufusB

Hi Drazen, I'm afraid that doesn't work, I've tried it many times, also "rolling" the key. In passing, the test key doesn't work either.

September 24, 2020 at 1:14 pm #7091749

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello,

thanks for the feedback.

In order to investigate this issue and to understand it better, I would need to access your website.

If possible create a staging site where I can check the issue safely, otherwise create a backup.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the private fields mentioned.

You can safely add your information into these fields.

Kind regards,
Drazen

September 25, 2020 at 8:26 am #7097559

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello,

thanks for sharing info.

I recently found that the option at checkout to pay via Stripe when USD is the chosen currency has gone

I have checked your site and it seems all is working fine. I can see the Stripe payment option both in EUR and USD, image attached.

Maybe I have not understood your issue correctly, please check and let me know if you still have an issue and steps how can I check it.

Thanks and kind regards,
Drazen

September 25, 2020 at 8:53 am #7097711

rufusB

Hi, I also noticed previously that the option to pay with Stripe disappeared but it returned when I replaced the Keys. That was a few weeks ago. I'm not sure why that would return now but I also see the option is available.

The issue now is that payment with secondary currencies through Stripe doesn't work, see attached. I guess to test this, you have to make purchases, which I will of course refund if they succeed, or I could make the purchase when you need a change tested.

Regards,

Rufus

September 25, 2020 at 2:45 pm #7100945

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello,

I have enabled Stripe test mode and added a test key for USD.

I could see the issue happening as you explained and Stripe error message:

[message] => Invalid currency: . Stripe currently supports these currencies: 

I saw some other plugins causing issues with Stripe, so I have disabled all plugins except for WPML plugins and Stripe, and switch to the WP default theme.

Then I went to the Multicurrency setting, changed the default currency for Stripe payment for USD, from GBP to USD, save. Then again changed to GBP and set the test key, save. Now it seems to work fine.

I have then tried to enable back again to see if it works, and it seems to be working fine.

I guess there was an issue in how WPML settings were saved or were not saved correctly because of interference with some other plugin.

On the checkout page, when Stripe is configured correctly there should be a message saying payment will be made in GBP even if the prices are in USD; check the image attached.

Please test and see if the issue still happens, please note you will need to re-add correct keys to the WCML setting and disable Test mode for stripe.

If you still have issues please provide FTP so I can check if there are some other errors happening with other plugins enabled.

Thanks,
Drazen

September 25, 2020 at 5:10 pm #7101977

rufusB

Hi, that didn't work I'm afraid. However, I found there are other stripe plugins so I changed it and it now works fine. WooCommerce Stripe Gateway plugin seems to have been the problem. Thanks for your time.

Cheers. and it now works fine. Thanks