This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bobby 3 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 19, 2019 at 12:46 pm #4051559

baldurA

I have a 2 translations of my pages, and the pages are built with Divi builder.
The translated pages do not have the complete styling that is from the original. fx. padding not being the same.

here you can see the original: hidden link
and here is the translated version: hidden link

June 19, 2019 at 6:52 pm #4054097

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Please go to your page and edit the default page , use the language switcher at the top and open in a new tab the translation (if you get a warning proceed anyway)

now compare the two and check your padding settings within the translation , once set as desired update the page and let me know your results

June 20, 2019 at 9:21 am #4058075

baldurA

That is very strange, and to be honest, is not what WPML is selling.. why does it take some styling but not all?

and then i have a bigger issue, the Chinese version of one of my pages is completely unusable.

hidden link
hidden link

June 20, 2019 at 6:36 pm #4062445

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

This is not the usual case , when translating using the WPML Translation Editor the styling should be the same in both the default language and translation.

1. were you able to resolve the styling following the above method ?

2. If you create a new test page and add similar styling , are you able to reproduce the issue ? if yes i would like to take a closer look to test for compatibility issues , and if not i believe something just might have gone wrong with the specific page and my steps should help to resolve it.

Regarding the second issue as we do try to keep each issue separate if possible please open a new thread and we will be able to review it separately

Thank you,
Bobby

June 20, 2019 at 6:39 pm #4062453

baldurA

Lets say i have no translated pages, and i create a new spanish version of a page, only a part of the styling is duplicated. Am i doing something wrong?
Or am i forced to go into every language and restyle every page that i create to fit the original?

June 20, 2019 at 7:25 pm #4062749

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If you are able to replicate this behavior with a new page then i would like to take a closer look at this.

if possible please provide me with a test page that has the specific styling that is not being copied over so i can better test the issue.

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

NOTE : if providing access to the site or a staging environment is not possible at the moment please provide me with a duplicator package to further test the issue on my local environment

Thank you,
Bobby

June 25, 2019 at 7:19 pm #4086951

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

this issue was happening due to some custom fields set to "Dont Translate" such as _et_pb_gutter_width which was not allowing the custom width and padding to show in the translations when using the WPML Advanced Translation editor.

going to the default language page -> edit page-> show system fields and setting these fields to "copy" resolves the issue.

Please find the steps to fully resolve the issue bellow:

1. Go to Edit your default language page
2. Make a small edit and update
3. Click on "loading circle" icon to edit the translation and re deliver the translation from within Advanced Translation Editor