This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Wolfgang Männel 4 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
May 27, 2019 at 7:31 pm #3900569

Wolfgang Männel

I am trying to: Translate to the subfooter

Link to a page where the issue can be seen: hidden link

I expected to see: the German translation

Instead, I got: The English text.

Site is password protected:
user name: rb
pw: ligigupe

Thanks!

May 28, 2019 at 4:23 am #3902663

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 28, 2019 at 7:08 am #3903159

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and enabled ‘FOOTER COPYRIGHT TEXT’ field translation by selecting tds_footer_copyright checkbox from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> td_011 and hit apply button.

And added test translation from WPML >> String translation and it appearing correctly at frontend as you can see in the attached screenshot.

You can update translation from WPML >> String Translation.

Please let me know if this resolves your issue or you need further assistance.

Thank you

May 28, 2019 at 8:25 am #3903985

Wolfgang Männel

My issue is resolved now. Thank you!

May 28, 2019 at 4:01 pm #3908729

Wolfgang Männel

Hello Noman, I noticed something very strange. The English Footer is being overwritten with the German version on the English language site. I change it in the Newspaper Theme Panel Footer-subfooter settings to English and it works fine. After a few minutes, even on the English page, I will have the German translation. Can you activate private messaging, so that I can send you new user coordinates? Thanks!

May 29, 2019 at 4:16 am #3911667

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have enabled private input box for your next reply.

=== Please backup your database and website ===

Thank you

May 29, 2019 at 8:35 am #3913225

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have changed the string default language to German by selecting “admin_texts_td_011” checkbox and selected new language from ‘Change the language of selected strings’ dropdown as you can see in the attached screenshot.
Then I added English translation from WPML >> String Translation and now footer showing correct translation in frontend.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

Thank you

May 29, 2019 at 8:50 am #3913531

Wolfgang Männel

Perfect, thanks!

May 29, 2019 at 8:01 pm #3918381

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

[ changing ticket status ]

May 29, 2019 at 8:03 pm #3918383

Wolfgang Männel

Noman was able to solve the problem in no time at all. Great guy!