This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Juan 1 month ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 5, 2019 at 5:27 pm #4521051

Juan

Hello,

I have my original form created with Contact Form and this code (it is Catalan):

<label> Nom
[text* your-name] </label>

<label> Email
[email* your-email] </label>

<label> Assumpte
[text your-subject] </label>

<label> Missatge
[textarea* your-message] </label>

[acceptance acceptance-733] He llegit i accepto la <a href="hidden link">Política de privadesa</a>. [/acceptance]

[recaptcha]
<br>

<label>
[submit "Enviar"]</label>

I have followed this instructions for the translation:
https://wpml.org/2019/02/announcing-contact-form-7-ml/

But when I go to Translation Management, the Submit line doesn't appear, so the button can't be translated to English, and it's shown in Catalan (Enviar)

hidden link

Please, help to solve this problem.

Thanks.

September 5, 2019 at 6:30 pm #4521483

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Juan,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 6, 2019 at 7:58 pm #4527219

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I tried to access your website to give a detailed look in your issue, unfortunately there's still a first login screen before reaching the WordPress admin login (see attached screen). Can you please, provide me with this password as well? A private reply is enabled again. Thank you for your collaboration and patience, have a nice day.

September 7, 2019 at 3:00 am #4528273

Juan

Hello,
The password is: penta
But it shouldn’t interfere in the error.
We need to translate the button text on the contact form as soon as possible. Why the rest of the code lines are shown in you plugin but the submit code is not there? I don’t understand.

September 10, 2019 at 1:15 am #4540741

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

September 10, 2019 at 2:39 am #4540985

Juan

Hello Marcos,
I have tried to access using private mode and it’s working as a charm.
hidden link

September 10, 2019 at 4:37 pm #4547363

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Juan,

Thank you for the updates. Can you please provide me with a full step by step on how to access your WordPress Dashboard? I tried it with the provided url (hidden link) and it really doesn't work. Is there any contry/ip restriction? Please, let me know, thank you for your collaboration and understanding, have a nice day.

September 10, 2019 at 5:12 pm #4547647

Juan

Maybe it's the security plugin. I have deactivated it.
Try it now with:

hidden link

Same user name and password.

September 10, 2019 at 7:29 pm #4548501

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Juan,

Thank you for the updates. I tried to access the provided url still not possible to reach your WordPress Dashboard, a working WordPress Dashboard access will help us to speed up our support efforts and provide you with a solution in the shortest time possible. Thank you for your collaboration, have a nice day.

September 10, 2019 at 7:36 pm #4548523

Juan

Sorry. I don’t know what else I can do. I have disabled the iTheme Security plugin. And if I test the login in Incognito Mode, everything works fine. Can you use a VPN system or maybe upscale the case to other WPML supporter?
Thank you again.

September 10, 2019 at 8:29 pm #4548813

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

September 11, 2019 at 10:20 am #4552485

Juan

OK. So there is a problem.
But I need to solve the translation ASAP. You said:
"For now, you can translate the submit button using the WPML Classic Translation editor from your WordPress Dashboard > WPML > Settings > How to translate posts and pages settings."
And then, what can I do to translate the English button text? The rest of the form is translated to English.

September 11, 2019 at 10:35 am #4552661

Juan

My issue is solved now. I have created a new Form in the new language. Your advanced translation system didn't help me, and I have wasted a lot of time. Avada and your Plugin are not fully compatible as advertised. Please, solve it.