If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Carlos Rojas 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 16, 2019 at 11:10 pm #4768867

oulaC

the site was perfect and language all appear wella and suddenly this error occurs

It looks like languages per directories will not function. Details

when i clicked on details:
This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file
How to fix
When WPML accesses hidden link it gets:

i did what they suggest to do but nothing change the arabic link has disappear totally from the website

October 17, 2019 at 12:43 pm #4773739

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

October 18, 2019 at 9:58 am #4780403

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I took a look at the site and I would like to ask you to follow this steps:
- Create a full backup of the site.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Go to WPML -> Languages -> Language URL format -> Click on the 'Create root page.' and create the root page. I recommend you to visit this link where you will find our official documentation about this configuration: https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#what-is-a-root-page-and-do-i-need-one

Could you tell me if after the steps above the site works correctly?

Regards,
Carlos

October 18, 2019 at 3:11 pm #4783859

oulaC

I think it is working now, I appreciate if you check if everything is ok, but something happens, now if I write hidden link nothing will open I have to write hidden link otherwise the website won't open

October 21, 2019 at 8:33 am #4792263

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

In this case you need to go to WPML -> Languages -> Language URL format -> Deselect the 'Use directory for default language' option and save the changes.

This will leave the homepage as '/' and the homepage in secondary language as '/ar'

Regards,
Carlos