This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 2 voices.

Last updated by philippeD-17 5 months ago.

Assigned support staff: Jamal.

Author Posts
December 16, 2019 at 6:19 pm #5140595

philippeD-17

I am trying to: Show SuperStoreFinder (through its shortcode) in all languages

Link to a page where the issue can be seen: hidden link (shows fine here)
hidden link (no show here)
hidden link (no show here)
hidden link (no show here)
hidden link (no show here)
hidden link (no show here)
hidden link (no show here)

I expected to see: SuperStoreFinder to appear where it does not.

Instead, I got:

This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. maitres-installateurs

JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:552

Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified

You have included the Google Maps JavaScript API multiple times on this page. This may cause unexpected errors. js:168:216
$i hidden link
jj hidden link
Load hidden link
<anonymous> hidden link
<anonymous> hidden link

Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified
Use of Mutation Events is deprecated. Use MutationObserver instead.

XML Parsing Error: mismatched tag. Expected: </br>.
Location: hidden link
Line Number 190, Column 278: ssf-wp-xml.php:190:278
XML Parsing Error: mismatched tag. Expected: </br>.
Location: hidden link
Line Number 190, Column 278: maitres-installateurs:190:278
Google Maps JavaScript API warning: InvalidKey hidden link

December 17, 2019 at 4:03 pm #5148649

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

I can see the issue, the map and the section above it are not showing in all secondary languages.
I don't think that the errors in the console are relevant to this issue because they show up also for the default language, where the widget is working.

Instead, I think, that the issue is probably with the shortcode not being configured to support WPML. Can you give more details about this shortcode? What is it? What component(theme or plugin) declares it?

You can check this section of our article that could help you produce a configuration code for the shortcode if it is not configured?

Finally, can you tell me how are you translate the page? Through the translation editor or manually?
If it is through the classic translation editor, can you see the shortcode in the editor?

Maybe you want me to take a deeper look into your website, your next reply would be private if you would like to share a user/password with me, please take a database backup before.

Best regards,
Jamal

December 18, 2019 at 9:50 am #5153967

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Philippe,

Everything seems to be done correctly. Trying to configure the shortcode with the following code did not help.

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>SUPER-STORE-FINDER</tag>
        </shortcode>
    </shortcodes>
</wpml-config>

I suppose that the shortcode was never working before(could not find a previous case or documentation) or that a bug was introduced in the theme/plugin or WPML.

To verify this, I would like to try to reproduce this issue minimally in one of our test servers, If we do, I'll be able to escalate this issue to our compatibility team.
Please use the following URL to login to our test server
hidden link

Then, configure WPML similarly to your website(French -> English) and create a couple of stores, a page similar to "Maîtres installateurs" that will use the shortcode, then translate the page. If the translated page presents this issue, I'll escalate it to our compatibility team for further debugging and eventually a fix.

I hope it is not too much to ask, but it will definitely accelerate the resolution of this ticket.

Best regards,
Jamal

December 18, 2019 at 6:14 pm #5157305

philippeD-17

Hello Jamal,

I have done what you've asked me to do on your test site...

It works, so for you... It's good news 🙂 (Please make sure no one is abusing my client's Google Maps API 🙂

Unfortunately for me, it does not work on mine. I've tried to make a page (master-installers-2) without the use of WP Bakery and without the WPML advance translation... The shortcode does not appear in the translation area.

I will try again but this time I'll create the page directly in the other languages to see if anything changes.

I do not know what else to try after that..

Perhaps by doing it, it will give me other ideas..

I Hope you can keep on helping me further...

Best Regards,
Philippe

December 19, 2019 at 4:08 pm #5164763

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Philippe,

Yes, of course, none will be using the Google Maps API, and we'll delete that server as soon as we resolve this ticket.

As this issue was not reproduced on our test server, it is not a compatibility bug. Maybe it is caused by your actual server or another component in your website(theme/plugin).

For the first possibility, we'll create another installation on our platform and I'll ask you to migrate your website on it.

But first, let's check if it is not caused by another component, please check if this issue appears when:
- Only WPML plugins are activated. It will tell us if there is an interaction issue with another plugin.
- The theme is set to a WordPress default like Twenty Fourteen. It will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

If it does not help figure out the root cause, I'll create a new Installation on our platform and give you the steps to follow to migrate your website on it.

Best regards,
Jamal

December 20, 2019 at 12:08 am #5166839

philippeD-17

Dear Jamal,

I may have found the guilty plugin 🙂

I first deactivated our theme "Archi" but that did not change anything...

I then deactivated all the plugins with the exception of "SuperStoreFinder" and "WPMLs"...
That didn't do it either.

I then deactivated all the plugins with the exception of "SuperStoreFinder" and "WPML Multilingual CMS"..

That did it!

Reactivating each plugin one by one until I reached "WPML String Translation"...

As soon as I reactivate "WPML String Translation" it breaks the shortcode...

Please let me know what you think...

Looking forward to your feedback.

Best Regards,
Philippe

December 20, 2019 at 8:57 am #5169453

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Philippe

Ce problème avec String Translation se présente juste sur votre serveur. Sur le serveur de test String Translation ne cause pas de problème. Je dirais donc qu'il y a quelque chose d'autre sur votre serveur qui pose ce problème.

Pour investiguer d'avantage, j'ai créé une autre installation sur notre plateforme et je voudrais qu'on y migre votre site.
Veuillez suivre les étapes sur mon message privé(DECEMBER 20, 2019 AT 8:57 AM) pour migrer votre site dessus.

Cordialement,
Jamal

December 20, 2019 at 3:55 pm #5171609

philippeD-17

Bonjour ou bonsoir Jamal,

Bon.. J'ai migré le site sur Cloudways... Apparemment tout c'est bien passé apart que j'ai une page blanche quand j'essaye de suivre le lien fourni par votre server a la fin de l'opération migratoire. L' URL est different.e donc voila, sûrement pour ca.

Maintenant moi, je ne peux pas attendre que vous résolviez le problème... Donc je vais retirer Super Store Finder pour WP et l'installer directement sur notre server (la version NON WP), et je l'ajouterais au travers d'un.e iframe, comme ca je peut re-activer "WPML String Translation" et continuer mon boulot 🙂

Comment restons nous en contact ?

Comment je vais savoir la progression et quand le problème sera résolu ?

Merci d'avance et à bientôt j'espère,
Philippe

December 20, 2019 at 4:29 pm #5171745

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Phillipe,

Je pense qu'il s'agit plutôt d'un problème sur votre serveur. Ou du fait que vous utilisez une root page sans spécifier un fichier(html ou php) ou une page de votre site.
https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Par ce que j'ai du désactiver cette fonction sur le serveur migré pour pouvoir le rétablir(problème de la page blanche).

Voici par exemple page anglaise qui fonctionne bien hidden link

Pourriez vous demander au support de l'extension et au support OVH de nous aider à comprendre mieux la cause du problème?

Cordialement,
Jamal

December 20, 2019 at 10:48 pm #5173007

philippeD-17

Dear Jamal,

The problem I have with what you're saying is to define the home page because I have installed WP under a subfolder like this: hidden link
to develop the site first and also because I find it more secure and less hackable.

(is this a problem for WPML?) I think I have done it before and it worked..
(is this a problem for SSF?) Possibly..

I then change my URL like this:

Adresse web de WordPress (URL): hidden link
Adresse web du site (URL): hidden link

I see on your test server that you have removed the folder "plafonds"

Is it what you mean by "Par ce que j'ai du désactiver cette fonction sur le serveur migré pour pouvoir le rétablir(problème de la page blanche)."

What did you have to deactivate?

I don't understand what you mean there?

Je ne suis pas sur OVH... Le site a été construit sur OVH par contre... Ou vois tu que je suis sur OVH ? C'est marrant ca (lol)

Cordialement,
Philippe

December 21, 2019 at 9:18 am #5174863

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Philippe,

My apologies for mentioning OVH, I think I confused your ticket with another one.

For the root page, I don't believe that using a URL to your installation folder is correct. The root page should be either:
- A file, HTML or PHP: my-root-page.html / my-root-page.php
- A WordPress page.
If you only need a root page that points to the primary language, you can use a php file that does a redirect, check this reply https://wpml.org/forums/topic/directly-redirect-to-language-specific-homepage/#post-585558

On the migrated site, I was having errors about the root page, and when I deactivated the use of a root page the problem disappeared and I was able to continue.

It is expected that on our server, WordPress won't be on subfolder "plafonds", because the migration is done from a location(yoursite.com/subfolder) to another location (ourinstall.com)

Can you approach SSF support again and ask them to help us on this, I am not sure how the plugin works to investigate it further. Maybe we can find what is blocking it on your server!

Best regards,
Jamal

December 22, 2019 at 5:59 pm #5180013

philippeD-17

Hi Jamal,

Regarding what you said here:
BEGIN QUOTE- Voici par exemple page anglaise qui fonctionne bien hidden link -END QUOTE

Cette page marche en Anglais parce-que "WPML String Translation" is disabled.

What I have notice though is that, this site should be in french by default. However, when I go in the "Chaines traduction" (for example), it seems to show an english flag instead with french in the content... which then cannot be translated obviously, and that is really annoying, but I do not know how to reverse that.

What I wanted to point out:

I did not build this site originally. The developer that did used Qtranslate-X; so the first thing I did was to use your "qTranslate-X plugins to WPML" but that did not work very well for me, and I ended up with stuff in english that should have been in french and who know what else.

Best Regards,
Philippe

December 24, 2019 at 9:48 am #5188979

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Philippe,

Indeed, String Translation was deactivated, I tested again and the issue is also reproduced on our server. I am not sure what to check further, that's why I approached our 2nd Tier for suggestion on this issue. I'll get back to you as soon as I got a hint.

About French strings registered as English in "String Translation"(Traduction de chaînes), you can change their source language, first, select the strings, then use the button at the bottom of the table to change the source language, check the attached image.

I'll get back to you as soon as possible.

Best regards,
Jamal

December 25, 2019 at 3:22 pm #5192863

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Philippe,

Our 2nd Tier nailed the issue down and found that this happens when a store description:
- Has linebreaks.
- It is translated in String Translation.

We confirmed the bug in the clean install and we're escalating this ticket to our compatibility team.

I'll get back to you as soon as they found something. Because of the current holidays, this may take a couple of days.

Thank you for your patience.
Jamal

December 27, 2019 at 4:46 pm #5201541

philippeD-17

Thank you Jamal,

I'm happy to read that your team has found the bug, truly.
I do understand that the holidays do not help in resolving things as quickly as it could, but my client's staff is also in slow motion until the 6 of January. So as long as we can give him a functional site by then, I'll be double happy 🙂

Happy New Year to you and your loved ones.
Philippe