This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Raja Mohammed 3 days, 10 hours ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 19, 2019 at 4:05 pm #4417387

laurenceC-6

Please can you fix this once and for all, its the 4th time I am raising a ticket due to WPML closing the others even though they are not fixed. I am quite busy so if I do not manage to reply in time, just do not close the ticket, it is very frustrating to keep raising news one.

As per the last ticket on this matter, please enable the private message so I can send you a login to the site (again).

Here are the other threads on it please review the latest (first in this list).
https://wpml.org/forums/topic/swatch-colours-missing-again/
https://wpml.org/forums/topic/swatches-3/
https://wpml.org/forums/topic/swatches-still-not-working-for-language-pages/

Thanks

August 20, 2019 at 6:45 am #4420821

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I see that you have created a couple of tickets for the same issue and it has been closed due to inactivity. We expect the client feedback for active support so that we can resolve the issue to the fullest.

It seems like your site is using an older version of WPML and which is causing the issue again. In our records, it is stated that the issue with variation swatches has been resolved in the latest version of WPML and WooCommerce Multilingual.

As a possible solution :
Please update your site to the latest version of WPML, If you don't see the update notice please try the below steps to manually update the WPML plugins

* Steps to manual update
-- Backup your site and database
-- Deactivate the WPML plugin from WP dashboard plugins section, This won't delete any data
-- Download the latest version of WPML plugins from https://wpml.org/account/downloads/
-- Upload a fresh copy of the newer version of the plugin
-- Activate the plugin
-- Once you have uploaded the latest WPML core plguin, goto Plugins -> Add New -> Commercial Tab , Install the required plugins

Please make sure the version of Varion swatches plugins is at least Version 3.0.11
https://wpml.org/plugin/variation-swatches-photos/

Let me know the results. As a reminder, if we don't get any reply from your side for more than 10days the thread will be closed automatically.

Kind regards
Raja

August 20, 2019 at 11:14 am #4423125

laurenceC-6

Ok thanks I will try this soon. No one informed me on other tickets that updates and (potential) fixes have been released, maybe because the tickets were closed. We have another issue preventing us updating all plugins, so I am not sure when I can do this, so do not close this ticket until we know this issue is resolved. I am concerned you auto close tickets to make it look like more issues are resolved with WPML than they are. If you want to check the status please email me for an update and i can let you know. Once its fixed I can mark it resolved myself in the form. Thanks.

August 21, 2019 at 5:11 am #4428077

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sure you will be automatically asked about the status of the ticket by our cleaning bot,
Please respond with any update at that. If not the ticket will be closed.

I am leaving the staus to waiting for user feedback, This will keep the ticket active for a week.

August 22, 2019 at 11:41 am #4438831

laurenceC-6

I have updated all plugins and WP, its all the latest as of writing this (except one plugin see below), but the problem still persists. See attached images in case you are having difficulty understanding the issue from all the tickets.

To repeat... translating a product option in WooCommerce results in the swatch disappearing on the foreign language site.

The only plugin not updated is "WooCommerce Additional Variation Images" because that has a long standing bug I identified and had to fix myself but WooCommerce are ignoring it and not updated me on the status, so I cant update it until they do.

August 23, 2019 at 7:00 am #4444591

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I can understand the issue now, Would you mind providing temporary access to your site? I have enabled private reply for your next response to securely share the access details.

Please let me know the URL where the issue can be seen.

Kind regards
Raja

August 26, 2019 at 6:26 am #4456149

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I think I understand the issue now, The swatches are attached to the English custom attribute values so once the values are changed in the translation it is unable to display the appropriate swatch in the translation the possible reason could be the swatches lost the connection with the translated attribute.

However, I could not see a way to restore the connection or make it work with translation. I might need complete access to your site (to alter certain thing).

I would request if it is possible for you to create a staging site for me so that I can take a deeper look into the issue with our disturbing your live site. or if it is okay for you I can clone your site to our private server for a detailed investigation. Let me know whatever works best for you.

Kind regards
Raja

August 29, 2019 at 7:24 am #4478209

laurenceC-6

Replying just to keep this ticket open

August 29, 2019 at 7:24 am #4478211

laurenceC-6

I’ll need a way to send you details privately when I have done the above

August 29, 2019 at 10:39 am #4480235

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Private reply enabled.

September 2, 2019 at 8:22 am #4495235

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the access, The issue seems to have been fixed in WooCommerce multilingual version 4.5.0.

However, this seems like a regression, I would like to isolate the issue in a new installation to confirm the compatibility issue. Please install the plugin WooCommerce Variation and swatch photos to the sandbox site

hidden link

The installation already has WooCommerce with sample products, WPML is already installed, activate and complete the setup, Try to recreate the issue. This will help me escalate the issue to the compatibility team for a detailed investigation.

Kind regards
Raja

September 2, 2019 at 8:37 am #4495327

laurenceC-6

I have just installed the plugin. Thanks.

September 2, 2019 at 8:42 am #4495337

laurenceC-6

I setup a product here for you and was going to test it but I dont think WPML is enabled?
hidden link

September 2, 2019 at 9:30 am #4495721

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

WPML is already enabled i have complete WPML set up to make it easy for you, Please check now.

September 9, 2019 at 8:35 am #4534691

laurenceC-6

Replying to keep this thread open

Also, why are you waiting on me now? You can see the problem on our site, you have a site setup for testing too. So can you please get back to me with the fix. Thanks.