This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Raja Mohammed 6 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 7, 2019 at 7:56 pm

stefanijaV

Hi!

I have a problem with swatches not showing on my website - in the shop grid section (new in, etc.) under product titles (as shown in the attached image of how it should be).

They did until I installed the WPML Multilingual CMS plugin. If you deactivate it now you will see the swatches appear again.

I hope you can help me with this.

Thanks!

April 8, 2019 at 4:41 am #3554215

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

It seems like you have enabled Multi-Currency with custom prices.

Go to WooCommerce > WooCommerce Multilingual > Multi-Currency > Currencies make sure the option "Show only products with custom prices in secondary currencies " is disabled - The option is useful only when you have Custom prices instead of the exchange rate.

I hope that helps you better.

Kind regards
Raja

April 10, 2019 at 9:21 pm #3581489

stefanijaV

Hi!
Thank you for responding to the ticket.
However, the currency is not an issue, can you please check the ticket again? The problem is with swatches not showing.
Thanks!

April 11, 2019 at 7:28 am #3584421

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,

Please share the access to the site it seems your site is protected and I am unable to access your dashboard. Enabled private fields.

Kind regards
Raja

April 11, 2019 at 9:41 pm #3593021

stefanijaV

Hi.
I don't see the private fields.

April 12, 2019 at 9:30 am #3597035

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sorry, I have enabled it again.

April 12, 2019 at 6:46 pm
April 15, 2019 at 5:08 am #3609769

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

This seems like a conflict with the theme, I have found a thread in your theme support on how to make the swatches appear on the translated product please apply their recommendation hidden link

Check whether the issue is same after clearing SG cache and test in a private browser.

Also please check with the theme support as the theme is already in our compatibility list is any issue then can reach us or fix from their side.

If you need further assistance, Please feel free to reach us.

Kind regards
Raja

April 18, 2019 at 7:10 pm #3641615

stefanijaV

Hi.

I deactivated all plugins and I see that the problem starts when activating WPML String Translation. Not only the swatches are not showing but the thumbnails on single product pages too.
Can you please help me resolve this?
Cache clearing doesn't fix it.

This is taking a little too long.
Thank you.

April 19, 2019 at 7:22 am #3643807

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

This seems more like a compatibility issue, I can see the issue happening in the shop page in your site. To isolate the issue Please install your theme and related functionality to the sandbox site hidden link.

This will help us identify the issue with minimal installation and escalate as soon as possible.

WPML is already installed in the site. Please create a few color attributes and add to the already created products.

Let me know if you can reproduce the issue in the clean installation. If you need any assistance please feel free to drop a message I will be happy to assist you.

Kind regards
Raja

The topic ‘[Closed] Swatches not showing’ is closed to new replies.