This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by laurenceC-6 4 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
March 5, 2019 at 3:26 pm #3274838

laurenceC-6

I am trying to: add colours to swatches

Link to a page where the issue can be seen:hidden link

I expected to see: colours to be able to change over for product variations based on english ones

Instead, I got: blank colours on language variations, you provided a fix and it did not work

March 5, 2019 at 3:33 pm #3274887

laurenceC-6

Hello this is an issue that has been going on for some time, can I get a fix for this issue as I cannot re-open the original issue ticket.

March 6, 2019 at 9:10 pm #3281293

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I just visited your site and I can see color swatches in the translated product. For example: hidden link

Can you please share with me a link where you are not seeing the swatches?

Also, make sure that if you are using images for the swatches, that you have run the media sync at WPML -> Settings.

March 19, 2019 at 9:41 am #3377483

laurenceC-6

Hello sorry we had to manually update swatches in different languages the english which shows the colours again but this is not a fix its a temp fix I will set up the swatches without the temp fix in staging2 site to show you.

hidden link

March 19, 2019 at 6:03 pm #3382319

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I am viewing the product here in the secondary language and I am seeing swatches: hidden link

Can you please tell me which product you are seeing the issue on?

April 9, 2019 at 3:33 pm #3568845

laurenceC-6

english
hidden link

spanish
hidden link

April 9, 2019 at 6:11 pm #3569929

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I am still seeing swatches for both of those products, I'm just not seeing the same available colors. Please go to WooCommerce -> WooCommerce Multilingual -> Attributes. Select the color attribute and run the sync. After this, update both the original and translated product, and then let me know if all of the colors are available.

April 10, 2019 at 8:47 am #3573651

laurenceC-6

Hello updated as per above and still the same issue

english
hidden link

spanish
hidden link

April 10, 2019 at 12:19 pm #3575917

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

April 18, 2019 at 4:58 pm #3640927

laurenceC-6

Just letting you know this is still an open issue so not to close it. The previous support staff has left, w will pick this up after the Easter holiday.

April 18, 2019 at 6:17 pm #3641427

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you so much for the update. Since you are continuing in the original ticket, you can close this one. That way, you do not need to continue updating in multiple places. Thanks!

May 31, 2019 at 10:25 am #3929737

laurenceC-6

Hi. I notice this issue still exists but all the tickets for it are being closed by WPML so they are not being looked into. Here is another on this issue here https://wpml.org/forums/topic/swatches-3/.

So please can we keep this open until WPML resolve this issue.

What is the status with it now please? Are you waiting on site access (which has been sent lots of times on other tickets!). If so, then allow me to reply with a private message. It would speed things up if I can choose to send a private message without waiting on you to let me. Thanks!