This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 31, 2019 at 12:39 pm

jeremyS-10

I am trying to:change the default language to german instead of english. We translated everything from english to german but when i switch the default language from english to german there are some things goin wrong. The language switcher in the menu is gone and also the footer on the german version is gone.

When you check the URL's below you see both versions are available when switched to german by default.

hidden link
hidden link

I expected to: just change the default language from english to german. We translated from english to german but we want now set it the default language in german by default. Unfortunatly i get this bugs that we don't see the language swithcer anymore and our footer is gone on the german version.

When the settings are set to english as default language everything works fine.

Hope you can help us out!

May 31, 2019 at 2:50 pm #3931323

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. We need to increase the MaxInputVars to 20000 - currently, you have them set at 3000.

For this, please try to set this variables in your php.ini:

max_input_vars = 20000;
suhosin.post.max_vars = 20000;
suhosin.request.max_vars = 20000;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

Please see if now things are back to normal.

If they are not, please try step 3:

3.

- disable all plugins except WPML and its add-ons (also leave the Divi theme enabled + Divi Layout Injector - V3.1 plugin)
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

Please let me know how that goes and what you will be able to find.

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai Apetrei

June 3, 2019 at 8:07 pm #3945895

jeremyS-10

Hi Mihai,

I just did the things you asked except for the MaxInputVars. Our hosting provider will fix this for us in the next days.

We added the code in the wp config file and deactivated al plugins except the divi theme and the divi layout injector, just like you asked. Unfortunatly this wasn't fixing the issue.

As last i also deactivated the divi layout injector to see if the language switcher was coming back. This wasn't the case.

So hope you can further investigate the issue for us. Can you let me know it the MaxInput Vars variable can cause this error? Because the system support (wmpl) status is ok and everything is in green.

Hope to hear from you soon!

Best regards

Victor de Vos

June 4, 2019 at 2:24 pm #3952693

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the feedback.

We can't know for sure what is causing an issue until we don't try to remove all the possible reasons. So that might be the reason but we can't know for sure.

Can you please let me know when the hosting provider can change that for you?

I will be waiting for your response.

Kind regards,
Mihai

June 5, 2019 at 6:33 am #3957389

jeremyS-10

Goodmorning Mihai,

Just checked and al the settings are set now.
I've tested your instructions again and deactivated all plugin's except divi, wpml and the layout injector. Still got the same issue that the language switcher is not showing up in the menu.
I've also tried with deactivating divi layout injector but still got the problem. Looks like it is a bug in WPML?

Waiting for your response..

June 6, 2019 at 11:40 am #3968791

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am trying to log into the site but the panel link doesn't work.

Can you please check?

I attached a screenshot of what I'm seeing.

Thank you.

Kind regards,
Mihai

June 6, 2019 at 1:46 pm #3969645

jeremyS-10

Hi Mihai,

Can you check again with this link?

hidden link

June 7, 2019 at 3:47 pm #3977555

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the link.

I can confirm that I was able to log in now.

Can you please create a full backup of the site and then go here (hidden link) and update everything to the latest version?

This might solve our issue.

From what I see, there's an update for the theme, too, so we always need to be on the latest version of the products we are experiencing issues with.

Can you please test again after you run the updates and let me know if you are still encountering issues?

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

June 9, 2019 at 8:50 pm #3983683

jeremyS-10

Hi Mihai,

Just updated everything. Can you please check whats going wrong tomorrow? We want to go live with our new website but unfortunatly this error is a big problem for us. We are now waiting for more then 10 days now for a solution.

Hope you can help us so we can go live in the next days...

Best regards
Victor

June 9, 2019 at 8:51 pm #3983685

jeremyS-10

For your info we also checked and still facing the issue...

June 10, 2019 at 4:58 pm #3988949

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for your patience and for trying what I recommended.

It seems the issue is indeed still happening.

I created this clean sandbox environment setup for you here: hidden link (one-click login).

WPML + the WPML add-ons are already installed, all I would need from you is to set up WPML as you have it on your site, install the Divi theme and try to recreate the issue on our servers, too (the idea of a clean sandbox environment is to avoid as much as possible to add any other extra plugins that are not needed, so we would need just the WPML plugins and whatever is needed to recreate the issue - theme or plugin).

If the issue is going to happen on our servers, too, that's when I can forward this to our Compatibility department developers as I think this might be a compatibility issue after all.

Will you please let me know when that's done and what is the result so that we can move forward with this?

Thank you very much for your cooperation.

I will be waiting for your response.

Kind regards,
Mihai

The topic ‘[Closed] Switch default language’ is closed to new replies.