Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Christopher Amirian 9 months, 2 weeks ago.

Assigned support staff: Christopher Amirian.

Author Posts
October 23, 2021 at 2:17 am #9847763

Santiago

Hello there,
I try to change the switch drop down from hover to click on mobile.
I test almost all the solutions I can see on your website but looks like is not working.
Looks like many people try this before.
Thank you in advance.-

October 25, 2021 at 6:15 am #9853725

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Would you please give us more detailed information on what you want to do?

Just to let you know, out of the box, the WPML language switcher in the dropdown mode and uses hover on desktop and on mobile as there is no such a thing as hover, you need to tap on the language to see the dropdown.

If I misunderstood something I'd appreciate it if you could give me more details so I can understand the request.

Thanks.

October 25, 2021 at 8:03 am #9854335

Santiago

Hello Christopher,
How I can share my website url just with you?
Thank you.-

October 25, 2021 at 12:39 pm #9857231

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Please set the next reply as private and you will be able the share private message.

Also it will help if I have the debug info alongside your description of the matter.

Would you please kindly follow the steps below to provide the debug information?

- Go to "WordPress Dashboard > WPML > Support > Debug Information (Link)".
- Copy the Debug Information from there.
- Get back to this chat screen and scroll down.
- Find the "Additional Data" section below. (Check the screenshot below)
- Click on the "Debug Info" item to expand it.
- Paste the debug information into the text area.
- Click the "Send Debug Info" button.

Screenshot:
https://wpml.org/wp-content/uploads/tmp/debug_info_20.png

Thanks.

October 26, 2021 at 4:03 am #9861187

Santiago

Looks like this is not private.
Please, how I can add a private reply?

October 26, 2021 at 1:05 pm #9864709

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

You just need to set the reply as private, you are going to find the checkbox on the next reply that you want to give.

October 26, 2021 at 11:47 pm #9869067

Santiago

Hello, looks like is not working.
I check the private option and I still seeing my reply on a different browser on incognito mode.

October 28, 2021 at 1:35 pm #9884363

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

I've got the email notification and managed to check your website.

The problem that you are experiencing is that your theme is not designed to have a dropdown mode in mobile and that is why even when I deactivate the current language clicking event, it still does not open the dropdown menu.

Your theme CSS code overrides whatever WPML has as default and that is why this is happening for you.

If you change the theme to the default theme of WordPress you will see that it is working ok.

As you seem to have an option on your theme to have separate menu items for mobile, I suggest that you enable the Custom Language switcher option from WPML > Languages

And set it to be linear and not dropdown. Then you can use the shortcode below to add it to the mobile menu:

https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#using-wpml-shortcodes

It will not be a dropdown but at least it will list the languages.

Thank you.

The topic ‘[Closed] Switch drop down from hover to click’ is closed to new replies.