This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.75 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: The language switcher is not displaying on the website.

Solution: The reason the language switcher was not showing up was because you had not translated your content. As you can see, I duplicated the homepage into the secondary languages and now the switcher appears in your menu. It will only display on pages that have translated content.

To translate the homepage that I duplicated, open each translation and click "Translate Independently". Then you can add your translations and click Update.

This topic contains 10 replies, has 2 voices.

Last updated by harrieM 2 years, 11 months ago.

Assigned support staff: Lauren.

Author Posts
October 25, 2016 at 10:34 am #1122453

harrieM

See my website on hoteldonandres.com. Login with user 'xxxx' and password 'xxxx'. [edited by WPML support]
Where do I have to insert <?php do_action('wpml_add_language_selector'); ?> in theme Bridge (Qode)?

October 25, 2016 at 3:24 pm #1122814

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

This will depend on where within your site you want the language switcher to display. If you want it built into the end of your menu, you can select that in the WPML -> Languages -> Language Switcher Options. If you want it to appear in a widgetzied area, you can go to Appearance -> Widgets and drag the Language Switcher widget to your widget box. If you want it to display in a custom spot in your site, then you would want to edit the theme template file and drop in this code where you want it displayed:

 <?php do_action('wpml_add_language_selector'); ?>

For example, if you want the language switcher to display somewhere in your header, then you would want to edit header.php (which you an do by going to Appearance -> Editor) and then adding that code where you would like it displayed. If you add it to a theme file, I suggest creating a child theme and copying the file to your child theme so that the changes do not get overwritten when you update your theme.

Please let me know if you need any further assistance and I will be happy to help.

October 25, 2016 at 3:51 pm #1122848

harrieM

Can you please have a serious look..? It;s NOT WORKING! Please don't give me a standard answer. As you could see in the printscreens, i did ajust it the way you told me. So please login on the website and have a look.

October 25, 2016 at 4:50 pm #1122897

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I will be happy to take a look. I will need the server authorization password to access your site, and also I deleted your login information from the original post as that is open to the general public.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 25, 2016 at 5:52 pm #1122943

harrieM

I'm not sure about the password for wordpress: so here is a new one: [removed by WPML support]

October 25, 2016 at 6:20 pm #1122963

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I need a username and password for the server authentication page (I have attached a screenshot). I can't even get to the admin page to login.

Also, please refrain from posting password or sensitive in formation in regular posts. Make sure that I have marked the field as private, this is for security reasons. I have edited the previous post, so please repost the updated WordPress admin password in the next reply, along with authentication credentials.

October 25, 2016 at 8:08 pm #1123012

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Neither of those is working. Please check with your hosting provider to see if my IP could be blocked or if they can allow me access. Next reply is private in case you need to update credentials.

October 26, 2016 at 7:55 pm #1123949

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I still can't access the login page, it is still asking for authentication per my screen shot above. My IP is 75.182.18.219.

October 27, 2016 at 3:03 am #1124056

harrieM

Hello Lauren,
there are no screenshots in your post..?? But before login in uou have to use 2x 'xxxxxx' [removed by WPML support] before you enter the WP-login screen. Is that te problem. It's an extra loginscreen for extra safety. So please 2x 'login'.

Gr.

Harrie

October 27, 2016 at 2:42 pm #1124545

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, that was the login that I needed. I was able to access the dashboard of your site and the reason the language switcher was not showing up was because you had not translated your content. As you can see, I duplicated the homepage into the secondary languages and now the switcher appears in your menu. It will only display on pages that have translated content.

To translate the homepage that I duplicated, open each translation and click "Translate Independently". Then you can add your translations and click Update.

Please let me know if you need any further assistance and I will be happy to help.

October 27, 2016 at 2:52 pm #1124552

harrieM

Hi Lauren,
Excuse for the misunderstandment about the 'login'. In the dutch language there's a clear explanation about that login in the pop-up. I saw that that explanation isn't there in the English version.
But I'm very happy that it's working now! Tx for your help. Wish you a nice day (i think it's in the morning in your place?
Greetings from the Netherlands!