If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Lauren 2 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
August 19, 2019 at 10:40 pm

רפאל בוסידן

I am trying to: make this page work with switcher and idon't see it

Link to a page where the issue can be seen:
hidden link
and
israeldc.com/profile

I expected to see: the switcher in both languages

Instead, I got: only in hebrew

August 20, 2019 at 12:49 am #4419557

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

thank you for the access details !

It seems that the translation was not fully saved for the page "My Account" due to the Advanced Translation Editor not saving properly

i went to WPML->Settings->"Synchronize Translators and translation managers" and then re accessed the translation and re saved it for the "My Account . " page.

this resolved the issue of the page not saving but the language switcher is still not showing in the front end.

1. how are you adding these pages ?

2. When i go to Pages->select "My Account" and try to edit its not allowing me to edit it same results with "My Profile"

August 20, 2019 at 4:38 am #4420521

רפאל בוסידן

Thanks for you're answer.

1. This pages include shortcodes and are auto created from an installation of a plugin. The other pages work fine with switcher.

2. Just a thought :
Maybe this pages conflict in databade because there ware pages like this on the pazt with woocommerce with shortcodes and pages had the names/permalinks?
2.

August 20, 2019 at 8:20 pm
August 25, 2019 at 12:50 pm #4454039

רפאל בוסידן

hi,
i see the pages are pending for translations, could that be the reason we dont see the changes ?
we am still waiting for reply or a solution if you have for this 2 pages

August 26, 2019 at 7:38 pm #4461069

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Bobby set up a clean install for you here: hidden link

Can you please install the plugin/theme you are using that creates those pages? This way we can try and reproduce the issue. If the translations are still pending, try marking them as complete and see if the switcher shows up.

August 29, 2019 at 1:38 pm #4481423

רפאל בוסידן

Hi, yes it seems to work on the sandbox .
i saw that this pages are waiting for translation but they are dynamic/taxonomies pages
Could that be the reason for this issue ?

August 29, 2019 at 1:49 pm #4481483

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I can see that you have more than one "My Account" page. Please delete the one that you do not need.

Also, when I try to edit the My Account page, I get the following message:
The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

Please resolve this error so that i can login and take a look at the page settings. If you need more information on the error, please enable the debug log in wp-config.php so that you can see which error is causing the message.

The topic ‘[Closed] switcher doesn't work on pages – my-account/ and /profile’ is closed to new replies.