Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 year, 11 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
October 22, 2018 at 4:21 pm #2838943


I dont know how to make the language switcher appear the mobile version of the site. The theme that I am using shares the desktop main menu with the mobile site, which is fine for one language. Since I cannot designate a different menu to be the mobile menu I dont know how to get the language switchers (either flags or language name) to appear on my mobile site. For some reason the entire main menu for desktop appears on the mobile version except for the switchers. (See attached images of both mobile menu without language switcher and desktop menu with language switcher.)

Pls advise.



October 22, 2018 at 8:03 pm #2839687

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for contacting WPML Support. Can you please, provide me with your website url address? I need to take a look if the markup for the language menu items are propely being output in your website. In some cases the theme css can hide these menu items on small screens for layout reasons. If it is possible I also would like to take a closer look in your WordPress Dashboard, it will help me to further review your languages switcher settings in order to give you a detailed solution, for that you should consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:


- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Thank you for your collaboration, have a nice day.

October 23, 2018 at 5:57 pm #2843730

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for getting in touch. Unfortunately I couldn't give a closer look in your WordPress Dashboard since the provided details don't seem to be correct. In any case, giving a look at the header main menu html markup, I could notice the following:

1 - Your language menu items seems to be placed on the header using a widget instead the proper feature to attach language switchers to the menu.

2 - The header widget content aren't visible on the mobile menu.

Based on this troubleshooting analysis I recommend:

1 - In your WordPress Dashboard > WPML > Languages > Languages, make sure you have a 'Menu language switcher' proper setup for your header main menu.

See: for the full details on how to setup your menu switchers.

Please, let me know if these solutions work for you and if you need any further clarifications, have a nice day.