Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by zvonimirF 4 years, 9 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
November 25, 2015 at 12:03 pm #754526

zvonimirF

I am trying to: Style the language selector and have the same order as in backend. For more plese see this topic was closed - https://wpml.org/forums/topic/langualge-switcher-order-on-backend-is-not-aplicab

URL of (my) website where problem appears: new.videntis.hr

I expected to see:

Instead, I got:

November 26, 2015 at 9:07 am #755395

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

#1
The ticket that you have mentioned leads to 404 error.
Could you please check the link that you would like to mention again?

#2
In the current WPML versions you can change the order of the languages appearing in the switcher via the settings under "WPML > Languages > Language switcher options".

But i guess, you are talking about the custom switcher right?

#3
Could you please share your debug information with me? So it will be easy for me to help you better. http://wpml.org/faq/provide-debug-information-faster-support/

I will wait for your feedback.

Thanks

November 26, 2015 at 12:39 pm #755600

zvonimirF

Hi Shekhar
the link is - https://wpml.org/forums/topic/langualge-switcher-order-on-backend-is-not-aplicable-on-frontend/

sorry for that

#2 I tried that (in above thread I've posted the backend img - what I see in backend is different from what I see on front).

regards,
Zvonimir

November 27, 2015 at 3:22 am #756196

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for getting back to us.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

I would also recommend to backup your database and website first before we proceed. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Thanks

November 27, 2015 at 10:13 am #756392

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for getting back to us.

In header.php line no.63 you have used the following code:

$languages = icl_get_languages('skip_missing=0&orderby=code');

Please use the following code so order can be defined in the WordPress admin under WPML » Languages » Language Switcher Option:

$languages = icl_get_languages('skip_missing=0'');

Please let me know if the above solution works for you, I look forward to your reply!

Thanks

November 27, 2015 at 11:37 am #756504

zvonimirF

Hi Shekhar,
this solved the issue!

Thnx for help! You provided me with excellent support.

regards,
zvonimir