This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.21 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 5, 2019 at 12:04 pm #4519011

kerenW

I am trying to:
Change language

Link to a page where the issue can be seen:
nayax.com

I expected to see:
the requested language

Instead, I got:
the default language (English)

my hosting company says that they think it is a chache issue, they want to know if there is something to exclude from the cache engine.

September 5, 2019 at 2:11 pm #4519997

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 9, 2019 at 10:45 am #4536023

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I would like to ask you to follow this steps:
- Create a full backup of the site.
- Update all outdated plugins and themes.
- Flush all cache memory.
- Finish the translation of the homepage.

Could you tell me if the issue disappeared?

Regards,
Carlos